CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Paraview Installation (

arunsmec February 17, 2012 00:45

Paraview Installation
I installed OpenFOAM using the source pack. While i was trying to run one of the tutorials, i encountered the following error.

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

But i had done these prior to running the tutorial. When i executed the ./allwmake i got the following message.

user@ubuntu:~/OpenFOAM/OpenFOAM-2.1.0/applications/utilities/postProcessing/graphics/PV3Readers$ ./Allwmake
+ [ -d /home/arun/OpenFOAM/ThirdParty-2.1.0/platforms/linuxGcc/paraview-3.12.0 -a -r /home/arun/OpenFOAM/ThirdParty-2.1.0/platforms/linuxGcc/paraview-3.12.0 ]

I am not able to understand what is wrong. What is the way out of this?
ps: I am an absolute beginner in UNIX :confused:

wyldckat February 18, 2012 07:16

Greetings Arun and welcome to the forum!

I didn't get an opportunity and enough time yesterday, but right now I've managed to focus a bit on this thread... but, you aren't providing much information as what exactly you've done and what errors occurred!

I've seen some issues similar to these a few days ago, so check there as well:

Best regards,

arunsmec February 18, 2012 10:16

Thank You
I installed using soure pack as directed in
I have followed the steps closely as i am new to Linux.
I could build the Openfoa using ./allwmake command.
Towards the end when i tried to run an example case (as directed) i got the error that
I was asked to do the folowing steps which i have done already.

cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

I have found similar problems in this forum. In one of the forums you have asked to check if some files are there in /opt.
But i extracted the files to home/arun/OpenFOAM/

wyldckat February 18, 2012 17:38

Hi Arun,

OK, I was expecting some more information, namely, which Linux distribution are you using?
  • Ubuntu?
  • Fedora?
  • openSUSE?
And which version?
  • Ubuntu 10.04 or 11.10?
  • Fedora 16?
  • openSUSE 12.1?
Best regards,

arunsmec February 19, 2012 00:20

Sorry for not mentioning!
Ubuntu 10.04

wyldckat February 19, 2012 07:28

Hi Arun,

Aaaaah HA! If only you had said that sooner ;)


Originally Posted by
OpenFOAM 2.1.0/x and building ParaView 3.12.0 on Ubuntu 10.04: paraview compilation error paraview-3.12.0 - post #9


Good luck!

arunsmec February 20, 2012 12:29

Thank you
But i cant connect to openfoam website. So I couldnt do what you have said. :(
I am using proxy to connect to internet. It could be because of that. I may try from somewhere else.:)

Sam-CFD February 21, 2012 00:30

I am not successful either in connecting to the OpenFOAM website and doing the installation from there. But I was finally able to successfully install from the source package, although I encountered similar errors as you mentioned.

You should do the following steps (I humbly must repeat that you should rigorously follow the steps as mentioned below, if you are a beginner with GNU/Linux):

1. You can set your proxy server ip/port along with username/password for your Ubuntu 10.04 following the instructions given here -

2. The next step is to install OpenFOAM and ParaFOAM, exactly according to the instructions given on the official website - I can assure you that if you obey all the instructions as stated there, you should be able to resolve the matter. Even if you tried it earlier, do it again, now that you have set the proxy server settings for your OS.

Hopefully it helps.


arunsmec March 13, 2012 11:42

Thank you all
Finally it is working. Sam, As you told i configured the proxy settings and installed all dependency packages 1 by 1. I guess that was the problem which i had.. Any way, thanks once again!!

nadine March 13, 2012 14:12

I am dealling with a similar problem, and i wish to get some help in here :)
I am new in the linux world, I installed an OpenFoam package for Fedora 15 from the OpenFoam site
and everything worked when i did the test.
Then i installed a Salome package ( i used the Madriva package which was recommended for fedora ) after that when i tried to use paraview i had this error:
FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
and when i tried to check the modules buy typing "module available", i had this second error: " init.c(479):ERROR:161: Cannot initialize TCL "
I tried to reinstall tcl, but i am getting a "nothing to do" message!!!
So please can some one help me!

Best Regards,

wyldckat March 15, 2012 18:59

Greetings Nadine and welcome to the forum!

The module that the error message refers to is a whole other kind of module, not the type that Fedora uses.

I won't be able to test this kind of installation any time soon, nor go into detail in trying to help you, so I suggest that you read the following blog post: Advanced tips for working with the OpenFOAM shell environment

Good luck!

nadine March 16, 2012 05:11

Hello bruno,
Thanks for answering me that quickly, but unfortunately your link didn't give me any information related to my problem.
I wish you had more time :(
Have a nice day,

wyldckat March 16, 2012 21:06

Hi Nadine,

I think my first guess was right, although I didn't make it very clear: the problem is very likely a collision of software versions that are present in both Salome and OpenFOAM.

By the way, which version for "Mandriva" did you use on Fedora 15? I tried the one for Mandriva 2010 and it simply wasn't able to run the installer!

Anyway, I installed the "Universal Binary for Linux" in my home folder and the solution was this:
  1. Re-edit the file "~/.bashrc":

    gedit ~/.bashrc
  2. Remove the two lines that were stated in step 3 from :

    module load openmpi-x86_64
    source /opt/OpenFOAM-2.1.0/etc/bashrc

  3. Add in place of them the following two lines:

    alias of210opt='module load openmpi-x86_64 ; source /opt/OpenFOAM-2.1.0/etc/bashrc'
    alias salome='$HOME/salome/appli_V6_4_0/runAppli'

  4. Save and close gedit.
  5. Now start a new terminal. If you want a working OpenFOAM environment, run:

    And that terminal is ready to use OpenFOAM.
  6. If you want to run Salome:

If you show us what the lines you've added to "~/.bashrc" look like, it'll be a loooot easier to help ;)

Best regards,

nadine March 17, 2012 10:53

Hello Bruno,

You are absolutely right! I am amazed by the fact, that you could guess what's the problem and find the solution without enough information from my part!
Actually the problem was that when I source, a problem appears with openmpi module which disfonction paraview, so yesterday before reading your reply, I tried another solution by adding another account where I only use salome! That's seems to work until now, but I will also try your solution.

And yes I installed Mandriva 2010.

Thanks a lot for your Help and the time that you consumed in order to solve my problem :)

Have a nice Week-end,

All times are GMT -4. The time now is 03:29.