CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Problem when installing Openfoam 2.0.x with mac (

giovaniharyadi March 24, 2012 19:45

Problem when installing Openfoam 2.0.x with mac
Hi Everyone,

I tried install Openfoam in mac and I followed this guide (source: )
HOWTO (only have to do all this ONCE):
1. Save the disk image (.sparseimage) in a convenient location
2. Mount the disk image; it will mount on /Volumes/Mac-OF-2.0.x
3. Do this in a terminal:
cd ~
ln -sf /Volumes/Mac-OF-2.0.x OpenFOAM
cd OpenFOAM
ln -sf ~/Documents/OF-User `whoami`-2.0.x
4. Edit your ~/.profile file in a text editor and add the following:
. ~/OpenFOAM/OpenFOAM-2.0.x/etc/bashrc
5. Quit and reopen the Terminal application; OpenFOAM is ready

I have already install Xcode, gcc45 then After I edit ~/.profile, I got this on my terminal screen :
-bash: mpicc: command not found

I tried type icoFoam in terminal and the message :
Giovanis-MacBook-Pro:~ giovaniharyadi$ icoFoam
dyld: Library not loaded: /usr/lib/libmpi.0.dylib
Referenced from: /Users/giovaniharyadi/OpenFOAM/OpenFOAM-2.0.x/platforms/darwinIntel64Gcc45DPOpt/lib/openmpi-system/libPstream.dylib
Reason: image not found
Trace/BPT trap: 5

Please help me to solve this problem. Many thanks.

All times are GMT -4. The time now is 16:44.