CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   [] Installing OpenFOAM 2.1.0 on ROCKS cluster (

aerospain March 26, 2012 03:23

Installing OpenFOAM 2.1.0 on ROCKS cluster
Hi all,

We are trying to install/compile OpenFOAM 2.1.0 on a ROCKS cluster from sources. I have taken another thread in this forum (which I cannot find again) as a reference, but that thread talks about OpenFOAM 2.0 through installation of CentoFOAM.

Besides the newest version of OpenFOAM which I would prefer to install, I am concerned as well with the version of the GCC compiler. This cluster has just 4.1.x installed in it and, with other simulation solvers installed, I would like to avoid updating the "main" gcc installation.

My questions are:
(a) Can I install CentoFOAM in this cluster and use a newer version of GCC which will be installed in the main OpenFOAM installation tree?
(b) Would it be easy to update OpenFOAM 2.0 to 2.1.0 after this installation?
(c) If I want to install directly OpenFOAM2.1.0 and related ThirdParty, which issues whould I be concerned about besides GCC version, and how can I make the installation/compilation last the shortest time possible?


linnemann March 26, 2012 07:00

Just install centFOAM

It will not do anything to your system.

It comes with its own GCC version 4.6.x.

There are multiple guides/help on how to compile OF on CentOS 5.x releases.

This thread has guide for OF-1.7 but the procedure is the same for 2.1

aerospain March 26, 2012 07:03

Thanks Niels,

We will follow those guidelines this afternoon


francescomarra March 27, 2012 04:50

I too use Rocks cluster to run OpenFOAM. To get everything working some time ago was not so easy. Essentially I was successful to install OpenFOAM following the suggestion of Niels.

If you like to read more (maybe too) detailed instructions for the installation, you can find them in the forum of the CFDEM third party software for lagrangian particle transport, I prepared some time ago (, search form for CentOS, maybe registration is required).
Essentially, I decided to install CentFOAM to get a working gcc installation separate form the system gcc.
The major effort was to recognize the environment variables to maintain separate the two compilers so to be sure to not break possible dependencies with the Rocks system.

Please note that I am not a professional system administrator: maybe better solutions could be available (modules ?). If you have comments or suggestions please let me know.

Best regards,


aerospain March 27, 2012 05:28

Hi Franco,

I will take a look at the information you mention. We tried yesterday with no luck because of different dependencies needed by OF21 with respect to gcc, mpfr, mpc, gmp, ppl, ...

I am visiting some people in another university at the end of this week and they may give me a few more hints from the system they have installed in their cluster.

Thank you for your help


sfalsharif December 15, 2014 03:25

Installing OpenFOAM 2.3.x (using centFoam) on Rocks Cluster 6.1.1

I'm trying to install OpenFOAM 2.3.x on a small Rocks 6.1.1 Cluster, and I'm a bit unclear on how to do it. I found centFOAM (thank you Niels Nielsen) and was able to use it to install OF on the head node, in my own home directory, according to the general advice of not installing as root. But what I need is to install it in a location so that all users are able to use it.

From what I understand from the Rocks Base Roll Guide, there seem to be to paths that can be taken to put code on the compute nodes:

1) If the code is an RPM package it can be placed in

, and a related entry needs to be added in a configuration file extend-compute.xml

2) If the code is not an RPM it can be placed in

on the head node. All the files will also be available to the compute nodes through NFS.

Now given that, I'm not sure how to proceed. The more obvious choice seems to put the code in /share/apps, and I've tried to specify that path when using the centFOAM python installer script, but that location requires root privileges. If I sudo install, the files are placed in the correct location, but then there are other complications: OpenFOAM thinks my home is in /root, the environment variable generally don't get defined correctly, the foam bashrc does't get executed (permission denied). Is there a more correct way of doing this?

I don't know anything about the other path: should I try to build an RPM for OpenFOAM? I've never done this before, and have no idea what is involved.

I would really appreciate any help or pointers on the correct way of doing this.



linnemann December 15, 2014 03:35

Hello Sharaf

the CentFOAM script only installs as the current user and if that user is root I would advise you to install it under /share/apps

If you do not have root access just install under your home dir, that is also NFS shared to all the nodes.

The problem I think you are facing is that the script only changes the baschrc of the user running CentFOAM so you might need to open that and apply to your user bashrc.

also check the OpenFOAM bashrc to check that the installed path matches the correct dir.

so for /share/apps/OpenFOAM install dir OpenFOAM-2.3.x/etc/bashrc would have to say


it could also help if you posted the install paths and content of the different bashrc files and also the error output you get.

All times are GMT -4. The time now is 23:29.