CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Native Meshers: blockMesh (
-   -   checkMesh error when incrasing nodes nb (

charlotte August 27, 2012 17:25

checkMesh error when incrasing nodes nb
1 Attachment(s)

I have some problems with blockMesh :confused:: when I add more nodes at my last 3 blocks, checkMesh returns garbage:

#0 Foam::error::printStack(Foam::Ostream&) in "/home/fnb/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/lib/"

whereas it works well with less nodes.
I tried:


and it works on one of my machine (but not on the server). I get the following warning in checkMesh:

Total nb of faces on empty patches is not divisible by the number of cells in the mesh. Hence this mesh is not 1D or 2D.
Zero or negative face area detected
number of severely non-orthogonal faces: 1
Error in face pyramids: 1 face are incorrectly oriented.
3 highly skew faces

With the other mesh (the one that works), there is NO warning, and it runs fine.

I attached a zip file with the 2 meshes in question... any insight would be great.



wyldckat August 27, 2012 18:30

Greetings Charlotte,

Interesting problem. Attached is a comparison between the bad (left) and the good (right) meshes.
As you can see, there are some weird flaws on the lower side of the mesh.

I tried defining in "controlDict" to save in binary, but the problem remained.

Try using a wider wedge for the more refined mesh. This should reduce these kinds of self-overlapping cells.

edit: ooops, I forgot to attach the picture :( I was almost asleep yesterday and ended up no attaching the image. Later today I'll attach it.

Best regards,

wyldckat August 28, 2012 15:59

1 Attachment(s)
Here we go, the picture I was talking about is attached to this post.

charlotte August 28, 2012 23:07

Thanks Bruno,

I tried to use wider angles and it didn't work out. I can see with paraFoam where are my bad nodes (always near the axis of symmetry), but clearly it's a bug in the blockMesh application. I tried to compile the same mesh with OpenFOAM 1.7 and it worked without any trouble. Time to get my hands dirty in C++...

charlotte August 29, 2012 20:28

ok, found the fix: a patch needs to be added for the axisymmetric axis, and the type must be symmetryPlane.

wyldckat August 31, 2012 05:20

Hi Charlotte,

I'm glad you've figured it out. And I noticed you had reported this as well ;)

Best regards,

All times are GMT -4. The time now is 18:44.