CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Open Source Meshers: Gmsh, Netgen, CGNS, ... (
-   -   Extruded Meshing fails (Linear search / could not find extruded vertex) (

Ijazu September 3, 2012 12:09

Extruded Meshing with gmsh fails (Linear search / could not find extruded vertex)
1 Attachment(s)
Hello everybody,

I am currently trying to set up a case for OpenFOAM using gmsh for the first time for creating the geometry. It includes extruded geometry which is then being copied and mirrored. But there seems to be a problem when meshing it. After meshing a couple of surfaces, gmsh prompts

Info : Meshing surface 1484 (extruded)
Info : Linear search for (8.539101721554962, 1.460898278445038, -10)
Error : Could not find extruded vertex (8.539101721554962, 1.460898278445038, -10) in surface 1484

three times. When meshing the volumes, the same error

Info : Meshing volume 62 (extruded)
Info : Linear search for (1.59871276638453, -0.1373313127625496, -10)
Error : Could not find extruded vertex (1.59871276638453, -0.1373313127625496, -10)

occurs many times, 515 times in total. This results in strange holes in the geometry, leading to missing cells.

I tried different meshing algorithms, with no success. I am using gmsh 2.5.1 on Ubuntu 12.04.

I attached the geo-file, a second file being included, the error log and an image showing the missing cells. I also added the .gmsh-options file. I would be very thankful for any help solving this problem.


mxylondon March 18, 2015 08:15

Hellow Ijazy, have you solved this problem? It seems I have the same problem now. Really confused.

All times are GMT -4. The time now is 12:17.