CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Open Source Meshers: Gmsh, Netgen, CGNS, ... (
-   -   Problem meshing an imported geometry (

Alicia March 30, 2010 04:53

Problem meshing an imported geometry
2 Attachment(s)
Hi all,

I don't really know if my post is in the right place here since I'm not using OpenFoam, but this one of the very few forums I found about GMSH.

I'm using GMSH to mesh geometry imported from Salome. I want to use the mesh function Transfinite Line with the option "Using Bump", which works perfectly with a geometry created in gmsh. When I try to use it with an imported geometry (my .geo file starts with Merge "geom.step"; (I also tried with .brep and .iges), the resulting mesh does not correspond at all with what I asked : I used the command
Transfinite Line(1)=14 Using Bump 4;
to refine the mesh at the middle of the line. What I get is only two points on the line 1, one at each end of it...
At first I had quite a complex geometry (a cubic volume with a hole in a 'radar' shape), so I tried with the simplest geometry : a quadrangle face. It doesn't work either, and here I get the right number of points on the line, but they are organised more like a geometric progression (each segment is x times the length of the previous one) than refine at some point.
For my complex geometry, I tried saving my file .step (or .iges or .brep) into .geo and then define the transfinite line with "using bump", but as it is a complew geometry when saving into .geo file several faces are skipped while exporting, and I can't mesh all my domain...
For the simple geometry, saving my .step file into .geo file and then defining transfinite line works.
I'd be very glad if someone here could help me !!! I'm stuck on this and can't find a solution so far...


I attach the .txt files corresponding to the .geo files with merge .spep. The geom.txt corresponds to my complex geometry and test_bump.txt to the simple one

All times are GMT -4. The time now is 01:25.