CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Open Source Meshers: Gmsh, Netgen, CGNS, ... (
-   -   problem with export mesh to file (

gm2011 January 26, 2011 13:01

problem with export mesh to file
Hi, Dear all,

I am trying to use Netgen to generate a surface meshing. However, I cannot export mesh to file. On my screen it shows that

Export mesh to file /opt/netgen/share/netgen/FILENAME, format is Surface Mesh Format Write Surface Mesh

However, I cannot find it. Is there anyone has any idea about this? Any commands will be appreciated.


philippose January 26, 2011 16:44


And a good evening to you too!

Just wondering.... do you have write access to the folder "/opt/netgen/share/netgen/" ? Usually only root has write access to files and folders under "/opt/...."

Maybe you should try to save the file somewhere else, for example, in your home directory... and see if that works.

Hope this helps!

Have a nice day!


gm2011 January 26, 2011 17:27

Hi, Philippose,

Thank you for responding! I really appreciate it.

I tried to save it in other directions, however, I cannot find the files no matter where did I save it. I followed the instruction here to install Netgen, but I failed when I install the last one ngsolve. Now I can start Netgen, but I cannot save the meshes.

Do you think it is something relate to ngsolve?

Thank you so much for your response and for your time.


philippose January 26, 2011 18:14

Hi again,

Nope.... It cannot have anything to do with the "ngsolve" part, because "ngsolve" is loaded into netgen as a DLL purely at run-time, and its absence does not affect netgen in any way.

Hmmmm.... have you tried saving another type of mesh? For example, can you try loading say... an STL file from the netgen sample files, creating a quick volume mesh, and saving it as a normal netgen mesh (using the "save mesh" option)? If this works... the next step would be to try and export (not save... but export) the mesh in the "netgen neutral" format and see if that works.

If these two functions do not work, then we definitely need to look into the matter in more depth.

Have a nice day!


gm2011 January 26, 2011 18:28

Hi again, Philippose,

Thank you for trying to help. If it is not about ngsolve, it must be something about my system.

I did what you said, load a STL file from the samples,
and created a volume mesh. However, when I click on 'same mesh' and save it to my Desktop, I got the error message:

can't read "inifilename": no such variable

Any suggestion? I have no idea what did I massed up. I have been using Ubuntu for a while, but still very bad at it.

Thank you immensely!


All times are GMT -4. The time now is 22:03.