CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... (
-   -   FluentMeshToFoam segmentation fault (

gtg627e October 16, 2007 13:05

Dear Forum, I am trying to
Dear Forum,

I am trying to convert a tetrahedral mesh saved from Fluent as *.msh to OpenFOAM. This is the error I get:

[gtg627eOpenFOAM@ruzzene03 simpleFoam]$ fluentMeshToFoam . plateHole prova3.msh
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.4.1 |
| \ / A nd | Web: |
| \/ M anipulation | |

Exec : fluentMeshToFoam . plateHole prova3.msh
Date : Oct 16 2007
Time : 12:54:34
Host : ruzzene03
PID : 19685
Root : /home/gtg627eOpenFOAM/OpenFOAM/gtg627eOpenFOAM-1.4.1/run/tutorials/simpleFoam
Case : plateHole
Nprocs : 1
Create time

number of faces: 766892
Number of points: 6716
Reading uniform faces
Reading points


#0 Foam::error::printStack(Foam: in "/home/gtg627eOpenFOAM/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt/"
#1 Foam::sigSegv::sigSegvHandler(int) in "/home/gtg627eOpenFOAM/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt/"
#2 ?? in "/lib/tls/"
#3 main in "/home/gtg627eOpenFOAM/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/fl uentMeshToFoam"
#4 __libc_start_main in "/lib/tls/"
#5 __gxx_personality_v0 in "/home/gtg627eOpenFOAM/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/fl uentMeshToFoam"
Segmentation fault


Doe anybody know what may cause this?

Thank you,


mattijs October 16, 2007 14:04

Did you try fluent3DMeshToFoam
Did you try fluent3DMeshToFoam?

hjasak October 16, 2007 15:01

Can you run this under gdb or
Can you run this under gdb or in a debug version? I am pretty certain you will have a zero area face or zero volume cell because flexing has finished with no errors. Ten to one your mesh is broken in some way. If you tell me more, I can fix this.


gtg627e October 16, 2007 15:10

Dear Hrv and Mattijs, I ha
Dear Hrv and Mattijs,

I have been working on this problem, and I think there is something wrong on my side. I am creating a mesh in ANSYS, importing in Fluent and saving it as *.msh. I think something goes wrong between ANSYS and Fluent. I will get back with the problem as soon as I figure it out.

Thank you for your prompt responses,


gtg627e October 17, 2007 19:15

Dear Hrv and Mattijs, The p
Dear Hrv and Mattijs,

The problem with Fluent is that my installation does not include tgrid or gambit. So, I can import my .iges file from ANSYS no problem; however Fluent only lets me save the boundary mesh, and not the entire domain. So, when I was trying to import my mesh in OpenFOAM, I was getting a segmentation fault error because I only had boundary faces.

I am trying to simulate the flow around a sphere, and given the short time I have, I swtiched to gmsh to generate my mesh. I am able to import it into openFOAM and run my case.

You should really consider ANSYSToFoam as an import utility. ANSYS so far has proven to be a far superior mesher than anything else I have used.

As soon as I get my simulation dialed in, I will post the gmsh file and the steps I am taking to run the simulation.

Thank you for you help,

Alessandro Spadoni

gtg627e October 29, 2007 09:56

Hello Forum, I finally solv
Hello Forum,

I finally solved my problem. One can easily import ANSYS mesh files as follows:

1. create your mesh in ANSYS.

2. To assign boundary conditions, select nodes at boundaries (this is best done by selecting an area at the boundary and then selecting the associated nodes with nsla,s,1) group them by assigning a group name with cm,outlet,,inlet,node...etc.

3. Now assign the domain element characteristics with: allsel,all, cm,fluidElem,elem

4. in prep7 archive your model, writing out a file.cdb, or alternatively issue cdwrite,yourfilename,cdb.

5. Transfer file.cdb into Fluent working directory.

6. Start fluent and do file --> import --> ANSYS --> file.cdb

7. Now you have your nice ANSYS mesh in fluent, including boundary condition definitions.

8. Now save your mesh in Fluent as: file --> write --> case (remember to uncheck "write binary files"). Your new file will have a .cas exstension.

9. tranfer your .cas file into OpenFOAM working directory.

10. Import mesh into OpenFoam as:
fluentMeshToFoam root case yourfile.cas


I hope this helps,


rauhpeha June 27, 2011 10:34

Hello Foamers,

gtg627e had a problem with importing an Ansys-mesh to openFoam, and he solved this problem. Now I tried to import an Ansys-mesh, too. But it does not work. openFoam does not read the .cas-file, although I used the command fluentMeshToFoam as described by gtg627e. The openFoam-output is:
Found end of section in unknown:)
Embedded blocks in comment or unknown:(
Found end of section in unknown:)
Found end of section in unknown:)
Found unknown block in zone:(
Found end of section in unknown:)
Found unknown block in zone:(
Found end of section in unknown:)
Found unknown block in zone:(
Found end of section in unknown:)

[ The smilies are originally ":" ")" resp. ":" "(" ]
Could anybody tell me what that means? Does anybody know about the mistake which I could have done?
thanks and regards

All times are GMT -4. The time now is 11:29.