CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Native Meshers: snappyHexMesh and Others (https://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/)
-   -   Installing HelyxOS on 32 and 64bit Linux Distributions (https://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/117183-installing-helyxos-32-64bit-linux-distributions.html)

wyldckat May 3, 2013 14:36

Installing HelyxOS on 32 and 64bit Linux Distributions
 
Greetings to all!

After several months of occasionally thinking about the topic of running HelyxOS anywhere and based on this comment:
Quote:

Originally Posted by santos (Post 375991)
I was able to compile and run HelyxOS on my 32bit openSUSE 12.1 system as long as I used Oracle's Java (did not work with the IcedTea version).

I've brainstormed a somewhat crazy idea yesterday where it should be possible to use VTK and OpenJDK which are provided in the latest Linux Distributions and make it work with HelyxOS! And I've managed to figure how to do it!

It's all documented here: https://sourceforge.net/u/wyldckat/helyxos/wiki/Home/ - and as of 2nd of November 2013, it's also here: http://openfoamwiki.net/index.php/Installation/Helyx-OS - this way more people can contribute!
The old documented/tested Linux Distributions and versions are documented in the old wiki page:
  • On CentOS:
    • HelyxOS on CentOS 6.4 32bit - (instructions derived from Fedora 17 32bit and CentOS 6.4 64bit)
    • HelyxOS on CentOS 6.4 64bit - (might work on 6.3)
  • On Fedora:
    • HelyxOS on Fedora 17 32bit
    • HelyxOS on Fedora 17 64bit
    • HelyxOS on Fedora 18 32bit
    • HelyxOS on Fedora 18 64bit
  • On openSUSE:
    • HelyxOS on openSUSE 11.4 32bit
    • HelyxOS on openSUSE 11.4 64bit
    • HelyxOS on openSUSE 12.3 32bit - also worked on 12.2
    • HelyxOS on openSUSE 12.3 64bit - also worked on 12.2
  • On Ubuntu:
    • HelyxOS on Ubuntu 32bit - 12.04 and 13.04
    • HelyxOS on Ubuntu 64bit - 12.04 and 13.04
    • HelyxOS on Ubuntu 11.10 32bit
(edit: all links were removed from the list above, given that they are no longer usable, since the old Helyx-OS versions are gone.)

For the more recent instructions, please visit the wiki at openfoamwiki.net: http://openfoamwiki.net/index.php/Installation/Helyx-OS

Note: these solutions rely on the system's own Open-MPI installation, therefore it does not require the hack with the symbolic link to "libmpi.so.0"!

I'll try to do some more tests on older distributions as well and report back!

Feel free to ask questions on this topic and to report back successful installations on other Linux distributions as well!


@Mac OS X users: try following one of these solutions, by using VTK and OpenJDK from Macports or something and share the solution you've gotten!

@Windows users: I'll have news in some time from now! Right now all I can say is what we've already said on the company where I work:
https://twitter.com/bluecapept/statu...63223267258370 :D (edit: We ended up dropping this effort.)

Best regards,
Bruno
_____

List of Linux Distributions that were tested and failed:
  • Ubuntu 10.04: VTK 5.2 is too old.
  • Fedora 16: VTK 5.6 is too old.
  • openSUSE 12.1: Had an issue with the Science repository and I gave up.
  • CentOS 5.8: VTK is missing from the EPEL repository.

JR22 May 3, 2013 16:10

Bruno, This is excellent news. I am a firm believer that software like this (eg HelyxOS, Discretizer, enGrid) are an excellent ice breaker for newbies like me and others. I saw that you also had updated a Windows version of the Discretizer. Thank you very much for these contributions.

wyldckat October 26, 2013 11:48

FYI: For those using Ubuntu or Debian, have a look to this thread: http://www.cfd-online.com/Forums/ope...t-helyxos.html

wyldckat December 1, 2013 16:21

News regarding Helyx-OS 2.0.0
 
Greetings to all!

I've finished writing and testing the latest instructions for installing Helyx-OS v2.0.0 in Ubuntu: http://openfoamwiki.net/index.php/In...elyx-OS_v2.0.0

As already mentioned in the first post, the instructions have been copy-pasted-updated to openfoamwiki.net: http://openfoamwiki.net/index.php/Installation/Helyx-OS

If anyone needs instructions for Fedora, CentOS, openSUSE or any other Linux Distribution, please let me know, so that I can add the instructions for the respective distribution!
And feel free to add to and/or improve these wiki pages!

Best regards,
Bruno

peteryuan December 7, 2013 14:11

Hi Bruno,

Thanks for you latest post. Very helpful!
I forgot one step.... now it is working.

peter

schwarczi October 26, 2014 20:21

Compiling Helyx-OS on OSX
 
Gents,

Has any of you had any success in compiling Helyx-OS on OSX so far? It would be great to have a step-by-step introduction or at least some pieces of advice.


Best,
Schwarczi

donminoti February 22, 2016 06:10

Greetings,

Please, any instructions to install HELYX-OS v2.3.1 on 32 bits Linux (ideally Ubuntu 14.04) ?

HELYX-OS v2.3.1, is the release that i can download, i could not find previous release for which instructions are set in wiki .

Thanks

wyldckat March 26, 2016 21:10

Greetings donminoti,

I've finally managed to give this a shot and I got lucky doing it only today :D.

The problem is that Helyx-OS 2.3.1 needs at least VTK 6.1 with Java bindings. Problem is that Ubuntu 14.04 to 15.10 do not have a working Deb package stack of both VTK 6 + Java bindings, which means that they cannot be used for a hack-and-switch strategy. For example, Ubuntu 14.04 does have a "libvtk6-java" package, but it's almost completely broken and useless for what we needed :(

Fortunately, Ubuntu 16.04 is already in beta 2 stage of development! And along with it, there is VTK 6.2 with Java bindings among the Deb packages! Although it still took some instinctive hack-and-slash strategy, I managed to figure it out.

The result - Instructions are now available on the wiki: https://openfoamwiki.net/index.php/I...elyx-OS/Ubuntu - for both Ubuntu 16.04 32 and 64-bit.

Now, here's the problem: You should only upgrade to Ubuntu 16.04 only around the end of May, after the initial bugs are all sorted out.

In the meantime, I'll try to check the other Linux distributions, to see if it's possible to do something similar.


As for the older instructions, they have been deleted, given that the old versions of Helyx-OS are not longer available :(

Best regards,
Bruno

edit: It's possible to install on Fedora 23 32-bit: https://openfoamwiki.net/index.php/I...elyx-OS/Fedora :) - but sadly it's not possible on CentOS/RHEL/SL and openSUSE :(

donminoti March 27, 2016 09:29

Greetings,
Thank you very much... i have immediately installed Ubuntu 16.04 after your Reply, however i wondering what about OF and Paraview on Ubuntu 16.04 !. with packages procedure it does not work, it's unbale to locate package !!!.

Thank you

wyldckat March 27, 2016 09:40

Hi donminoti,
Quote:

Originally Posted by donminoti (Post 591852)
Thank you very much... i have immediately installed Ubuntu 16.04 after your Reply, however i wondering what about OF and Paraview on Ubuntu 16.04 !. with packages procedure it does not work, it's unbale to locate package !!!.

OK... so you're hoping that no bugs will pop up with the beta version of Ubuntu 16.04. I hope you're lucky and you don't get any unwanted crashes! ;)

In order to use OpenFOAM on Ubuntu 16.04 means that you will need to install OpenFOAM from source code. Given that Helyx-OS 2.3.1 was designed to work with OpenFOAM 2.4.0, please try following these instructions: http://openfoamwiki.net/index.php/In...u#Ubuntu_15.04 - they work both on Ubuntu 15.04 and 15.10, so I expect they will also work on 16.04.

Best regards,
Bruno

donminoti March 27, 2016 09:44

This is what i'am trying to do...
let you know...
Thanks again

[ Moderator note: Posts about installation of OpenFOAM 2.4.0 on Ubuntu 16.04 have been moved to here: http://www.cfd-online.com/Forums/ope...u-16-04-a.html ]

donminoti April 6, 2016 13:53

Heyx 2.3.1 on RHEL (CentOs) 6.5
 
Hi Bruno,

I have installed Helyx Os v2.3.1, on CentOs 6.5 64 bits ( i can't use other releases), using binary file, i have followed the official instructions (that you recommend on wiki too) . Everything seemed to be well ... no error message during installation nor when i launch the application .
However when i execute meshing i have the following error:

* Run Mesh *
******************
Case : /home/donminoti/OpenFOAM/toto-2.4.0/RUN/cavity
Procs : 4
Log : /home/donminoti/OpenFOAM/toto-2.4.0/RUN/cavity/log/snappyHexMesh.log
Env : /home/donminoti/OpenFOAM/OpenFOAM-2.4.0/etc/bashrc
Vendor : /home/donminoti/OpenFOAM
Paraview :
MachineFile :
Solver :
/home/donminoti/OpenFOAM/toto-2.4.0/RUN/cavity/mesh_parallel.run: line 32: blockMesh: command not found
/home/donminoti/OpenFOAM/OpenFOAM-2.4.0/etc/config/settings.sh: line 369: mpicc: command not found

any suggestion ????

Someone else seems to face the same problem on this link:
https://github.com/ENGYS/HELYX-OS/issues/1

By the way , it works very fine on Ubuntu 16.04 ( Thanks:))
Thank you for your support.

wyldckat April 10, 2016 14:14

Quote:

Originally Posted by donminoti (Post 593729)
/home/OpenFOAM/toto-2.4.0/RUN/cavity/mesh_parallel.run: line 32: blockMesh: command not found
/home/OpenFOAM/OpenFOAM-2.4.0/etc/config/settings.sh: line 369: mpicc: command not found

Quick answer: In theory, it's because the OpenFOAM environment is not active in the command line before you launch Helyx-OS.
The other possibility is that you need to update the settings in the "Preferences" dialogue window.

Although, something isn't right in the output... this:
Code:

/home/OpenFOAM/toto-2.4.0/
should in principle be this:
Code:

/home/toto/OpenFOAM/toto-2.4.0/
namely the OpenFOAM folder should be inside your user-name folder!?

PS: And you're welcome :)

donminoti April 10, 2016 15:34

Hi,
Thank you for replying. Actually you are right for the folders path, i have drop out the user folder ( i correct it on the previous post !, sorry).
Setting "preferences" are set to " /home/donminoti/OpenFOAM/OpenFOAM-2.4.0", as you are suggesting in wiki.
I have tried to active OF with "of240" and then launch "Helyx-OS", still the same error.
Something went wrong, i have followed the instruction with "bin " file:
http://engys.github.io/HELYX-OS/installation/

Thank you again

wyldckat April 10, 2016 16:07

Hi Belamou,

OK, now I know what's the problem. I'm guessing you followed the installation instructions for OpenFOAM 2.4.0 from here: http://openfoamwiki.net/index.php/In...HEL#CentOS_6.6

There is a small detail that won't work with Helyx-OS: the alias "of240" is loading on-the-fly a few additional options, which Helyx-OS is not aware of.

Please run the following commands in the terminal/console window, with the OpenFOAM 2.4.0 environment already activated:
Code:

foam
echo WM_NCOMPPROCS=4 foamCompiler=ThirdParty WM_COMPILER=Gcc48 WM_MPLIB=SYSTEMOPENMPI > etc/prefs.sh

Now try launching Helyx-OS again and it should be ready to go!

It should now work as intended, because the on-the-fly options are now always present in the file "etc/prefs.sh", which is loaded automatically by OpenFOAM's "etc/bashrc".

Best regards,
Bruno

donminoti April 11, 2016 03:59

yes, You're the best , working !
However, still some error message on shell, and Helyx. but seem to not be a major errors. if interested the error message are bellow.
Thank you for the support.
Best regards

#############"
On the terminal: during meshing, runinng and launching paraview
#################
pci id for fd 64: 80ee:beef, driver (null)
libGL error: core dri or dri2 extension not found
libGL error: failed to load driver: vboxvideo
0 - pool-4-thread-1 - ERROR IOUtils
- Error reading file /home/donminoti/.HELYX-OS/tmp/tmp_1460366414/dictData/HELYX-OS/
createCase.mapFieldsDict: File '/home/donminoti/.HELYX-OS/tmp/tmp_1460366414/dictDat
a/HELYX-OS/createCase.mapFieldsDict' does not exist

******************
* ParaView *
******************
/home/donminoti/OpenFOAM/OpenFOAM-2.4.0/etc/config/settings.sh: line 369: mpicc: command not found
created temporary 'cavity.OpenFOAM'
############
This last one corresponds to the fllowing line in the settings.sh:

# Use the system installed openmpi, get library directory via mpicc
export FOAM_MPI=openmpi-system

(this line 369:) libDir=`mpicc --showme:link | sed -e 's/.*-L\([^ ]*\).*/\1/'`

# Bit of a hack: strip off 'lib' and hope this is the path to openmpi
# include files and libraries.
export MPI_ARCH_PATH="${libDir%/*}"


All times are GMT -4. The time now is 02:26.