CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Native Meshers: snappyHexMesh and Others (
-   -   Snappy failing at morph iteration (

plucas May 27, 2013 18:49

Snappy failing at morph iteration
1 Attachment(s)
I am using openfoam 2.2.0 using Ubuntu 11.10. I just upgraded to 2.2.0 from the last release of openfoam. The case I am working on is similar to one I did on the last openfoam release.

I have meshed around with the snappyhexmesh file for the last week and searching has left me without answers.

This case is an external aerodynamic study with a car. I have attached the snappyhexmesh log file and the snappyhexmeshdict file. Any help on this would be greatly accepted.

If any other files would help, I can upload those also. Thanks in advance for the help!

Haces May 29, 2013 17:16

Hi plucas,
If you want to use the explicitFeatureSnap I think you have to add the features before.

plucas May 29, 2013 21:47

What do you mean add before?

Haces May 30, 2013 04:25

I think that for the explicit features you need the edges. You import this edges in snappyHexMesh in a eMesh archive inside features. You have this part commented

plucas May 30, 2013 09:03

Ok, I will try to get the eMesh to work. I was running into problems with that also which is why it is commented out.

Do I have to call out the patches in surfaceFeatureExtract? Right now I just have the stl file called out in the surfaceFeatureExtract.

Haces May 30, 2013 11:17

You don't need to call the patches. The command surfaceFeatureExtract extracts the edges of the stl surfaces. To see the result you can create a .obj file and open it with paraview. To filter the edges you can for example eider use includedAngle or minElem. If you have OF 2.1 you can write surfaceFeatureExtract -help to see the different options. In OF 2.2 I don't know how to see the different options because surfaceFeatureExtract is a dictionary. Probably you can search it in the tutorials.

plucas May 30, 2013 11:56

Ok I will try this when I get home. Thanks for the help! And I will inform you how it goes.

plucas May 30, 2013 23:09

1 Attachment(s)
I tried the surfaceFeatureExtract and it failed. Maybe I should make a new thread on this... I have attached the files. I am completely lost of the problem after upgrading to the new release.

Haces May 31, 2013 04:03

Have you checked the quality of the surface?I think that the command is surfacecheck. maybe your problems come from this.
You can also try to use the implicit feature instead the explicit one. If you don't get an error you know were is the problem. But I'm still recommending the explicit method.

plucas May 31, 2013 06:15

I have tried implicit instead of explicit with no luck also. I have not checked the surface, but I will be trying that. That has to be the issue....

All times are GMT -4. The time now is 20:24.