CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Native Meshers: snappyHexMesh and Others (
-   -   snappyHexMesh after extrudeMesh / Creating background mesh with extrudeMesh (

pythag0ra5 August 12, 2013 05:00

snappyHexMesh after extrudeMesh / Creating background mesh with extrudeMesh
Dear FOAMers,

i want to run a procedure like:

1.) blockMesh
2.) snappyHexMesh -overwrite
3.) extrudeMesh
4.) snappyHexMesh -overwrite

In other words, the background mesh for the second snappyHexMesh-procedure should be created with extrudeMesh. My problem is, that the steps 1-3 works fine, but when i run SHM again (Step 4), i get an error-message:


Number of cells in mesh:16328 does not equal size of cellLevel:236700
This might be because of a restart with inconsisten cellLevel.

I asume, that i have to delete some files / directories, but as i am not sure about this, it would be very nie if you can gie me a hint!

Best regards!

Artur September 11, 2013 05:36

It's quite an old post, have you figured out the solution?

My bet would be:
a. delete all the cell sets, face sets, etc. from the polyMesh directory
b. remove all the files created by snappy in the 0 directory
c. check that all your boundaries are defined properly after the extrude mesh procedure; if not then use topoSet and/or createPatch -overwrite to create new patches or remove those with 0 faces in them

pythag0ra5 September 11, 2013 08:40

Hi Artur,

thank you very much for your reply, unfortunately my problem is not solved yet.

Meanwhile, i found out that some files in the polyMesh-directory have to be deleted (as you already mentioned in your post).

Right now, i think my that there is no solution for my desired procedure. This is because snappyHexMesh requires a background mesh which consists (only) of hexahedral elements. But an arbitrary shaped geometry will lead also to tetrahedral- / layer- / other elements, therefore (in my opinion), snappyHexMesh can only be used one time.

Best regards

Artur September 11, 2013 09:10

Well too bad it didn't work, would have been a nice tool.

Thanks for sharing your conclusions anyway!

All times are GMT -4. The time now is 06:17.