CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Native Meshers: snappyHexMesh and Others (
-   -   SnappyHexMesh hangs during refinement (

sjrees December 8, 2009 15:51

SnappyHexMesh hangs during refinement
I am trying to mesh a geometry consisting of a single background mesh box created with blockMesh and a single STL surface that will become the bottom of the box. This is a rough surface with a number of building outlines protruding into the flow.

I can get the mesh to refine to the first level but snappyHexMesh always hangs when trying to refine to the second level. I can an error:

>Surface refinement iteration 2
>[5] meshRefinement::checkData() : Found 0 duplicate pairs of faces.
>[7] meshRefinement::checkData() : Found 0 duplicate pairs of faces.
>Marked for refinement due to surface intersection : 9 cells.

The application is running flat out continually (100% cpu shown using top) from this point. Only a modest amount of memory is being used so I know it is not swapping at this point.

Any ideas please?

ziad September 11, 2010 10:43

1 Attachment(s)
Same problem here.

Meshing worked fine before then I shifted the outlet plane further downstream (flow around a 3D rectangular building structure) and sHM just hangs after the 4th mesh refinement iteration 2. This is the last "mesh refinement iteration 2" since I am running 4 threads in parallel. The other 3 complete no problem. Shifting the outlet domain further downstream merely adds a rectangular chunk of structured hex on the blockMesh side. sHM doesn't even do anything down there.

Tried refining/coarsening around the point where it was hanging but no luck.

Output from debug level 1 is attached and shows where sHM is hanging.

ziad September 11, 2010 12:29

obviously a snappyHexMesh bug
As posted previously, refining or coarsening the area of the problem did not help. Also tried playing with the mesh quality parameters such as allowing more or less concavity, using more smoothing iterations, etc. No luck there either.

Here's what worked: pushing the outlet plane of the domain a few more units downstream! Weird but consistent with the source of the problem. sHM started hanging when I initially pushed the outlet plane downstream.

Definitely a (rather exotic) bug! :p

wyldckat September 11, 2010 17:05

Greetings Ziad,

Could you report your findings about this bug here:

By the way, are you using the latest OpenFOAM 1.7.x version? If not, perhaps this bug might already have been fixed.

Best regards,

ziad September 11, 2010 21:59

Hi Bruno,

I'll report the bug.

Meanwhile I am using 1.7.0. Not planning to upgrade just for this though.


All times are GMT -4. The time now is 15:42.