CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Native Meshers: snappyHexMesh and Others (
-   -   sHM cannot find file (

nitsud March 4, 2010 02:40

sHM cannot find file
Hey all,
I'm trying to run snappy in parallel and keep getting the error:


[0] Cannot find file "" in directory "constant/triSurface"
[0]    From function Time::findInstance(const fileName&, const word&, const IOobject::readOption)
[0]    in file db/Time/findInstance.C at line 148.

The case works on a single core, but barfs on a multicore job. Hoping that someone has seen this before!!

foam_noob March 8, 2010 08:08

Hi Dustin,

after you run decomposePar. You have copy the triSurface folder into every constant folder of every processor folder (processor0, processor1...)
Snappy should run afterwards.


nitsud March 14, 2010 02:01

Thanks Patrick, that got it to run, but it's now failing on reconstructPar, again complaining about a missing file:


cannot open file

file: caseRoot/processor0/1/polyMesh/pointProcAddressing at line 0.

    From function regIOobject::readStream()
    in file db/regIOobject/regIOobjectRead.C at line 62.

FOAM exiting

Looked at each of the processors with paraFoam and each looked as expected.

foam_noob March 15, 2010 03:08


I've never had that problem when I worked with decomposePar so I have no idea what the problem might be. It's best if you search the forum.

Sorry that I couldn't be of more help.

sjrees March 15, 2010 05:09

I have managed to get SHM working in parallel and can offer a couple of comments.
i. You can just make soft links to your stl file in the processor directories rather than copying it lots of times.
ii. When doing the reconstruction after running SHM I found it necessary to use the -constant option to rebuild the mesh. I also found it necessary to increase the write tolerance to 10^-8 when using reconstructParMesh.

openfoam_user July 14, 2010 04:08


I am trying to run sHM in parallel.

When I run :

snappyHexMesh -parallel

I get the following error message

[250]cfs10-sanchi /shared/sanchi/OpenFOAM/sanchi-1.7.x/pippo % snappyHexMesh -parallel 12

bool Pstream::init(int& argc, char**& argv) : attempt to run parallel on 1 processor

From function Pstream::init(int& argc, char**& argv)
in file Pstream.C at line 73.

FOAM aborting

#0 Foam::error::printStack(Foam::Ostream&) in "/shared/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt/"
#1 Foam::error::abort() in "/shared/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt/"
#2 Foam::Pstream::init(int&, char**&) in "/shared/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt/openmpi-1.4.1/"
#3 Foam::argList::argList(int&, char**&, bool, bool) in "/shared/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt/"
#4 main in "/shared/OpenFOAM/OpenFOAM-1.7.x/applications/bin/linux64GccDPOpt/snappyHexMesh"
#5 __libc_start_main in "/lib64/"
#6 _start at /usr/src/packages/BUILD/glibc-2.10.1/csu/../sysdeps/x86_64/elf/start.S:116
[cfs10:09124] *** Process received signal ***
[cfs10:09124] Signal: Aborted (6)
[cfs10:09124] Signal code: (-6)
[cfs10:09124] [ 0] /lib64/ [0x2af77d069560]
[cfs10:09124] [ 1] /lib64/ [0x2af77d0694e5]
[cfs10:09124] [ 2] /lib64/ [0x2af77d06a9b0]
[cfs10:09124] [ 3] /shared/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt/ [0x2af77c16f7f1]
[cfs10:09124] [ 4] /shared/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt/openmpi-1.4.1/ [0x2af77d398b96]
[cfs10:09124] [ 5] /shared/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt/ [0x2af77c17ec49]
[cfs10:09124] [ 6] snappyHexMesh [0x40515a]
[cfs10:09124] [ 7] /lib64/ [0x2af77d055a7d]
[cfs10:09124] [ 8] snappyHexMesh [0x404639]
[cfs10:09124] *** End of error message ***

Any idea ?


openfoam_user July 20, 2010 09:04

I have found the solution reading the advices of W. Heydlauff. You don't need to copy the stl file into each processor* folder.

Hereafter isthe procedure.

- run "blockMesh" a usual
- decomposeMethode in decomposeParDict must be hirarcial
- run "decomposePar"
- run "foamJob -p -s snappyHexMesh"
- afterwards run "reconstructParMesh -mergeTol 1e-06 -latestTime"
(or -time 1; -time 2; ...)

Works perfect for the 3 steps of sHM:
castellatedMesh true;
snap true;
addLayers true;


All times are GMT -4. The time now is 03:29.