CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Native Meshers: snappyHexMesh and Others (
-   -   Meshing multiple blocks (

Hanno December 15, 2010 11:57

Meshing multiple blocks
1 Attachment(s)
Hello Foamers!

I needed to create a wall bonded Cube with an outlet that covers the hole backward face and an inlet which is only a small rectangular opening at the middle of the front face. The rest of the front face is defined as wall. In order to do this, i needed to create multiple blocks with BlockMesh (at least i dont know any other way). Ive made a very raw front view sketch of the block structure i created. The red face is the inlet.

The problem that occurs now, is that SnappyHexMesh is meshing only the BlockMesh defined block which contains the LocationInMesh point. Strangely it meshes all of the middle blocks if the LocationInMesh point is inside the red block. But not the side blocks. I wonder if its one of those paraFoam displaying bugs, but it seems not to be. I figure it is because im using distance wise meshing of the STL, which overlaps all of the three middle blocks but not the side blocks.

So my question is, is there a way to mesh multiple blocks with blockmesh? Thanks for your help.

Edit: I tried to work it out by defining a refinment box big enough to overlap all blocks, but it didnt work.

Hanno December 15, 2010 12:27

1 Attachment(s)
Sorry for repost, but unfortunately i could not edit attachments by the edit button.
The screenshot shows that it might be a BlockMesh problem, because ParaFoam shows me some boundary-like faces at the side blocks, but not at the middle blocks. But face matching should be done automaticly, so i dont have a glue of what BlockMesh is doing here.
CheckMesh sais:
"*Number of regions: 3
The mesh has multiple regions which are not connected by any face."
So why arent they connected?

Hanno December 16, 2010 06:52

I solved it by splitting up the two side blocks. But is there a way to mesh multiple blocks with snappyHexMesh?

J.Randall February 17, 2011 13:14

Same problem

I'm having the same problem, did anyone clever out there manage to solve it?


All times are GMT -4. The time now is 11:12.