CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Native Meshers: snappyHexMesh and Others (
-   -   bad trailing edge boundary layer with snappyHexMesh (

draufunddran February 15, 2011 08:42

bad trailing edge boundary layer with snappyHexMesh

i want to make a mesh around a naca-0012 with snappyHexMesh, but when i add boundarylayer i get this at the trailing edge of the airfoil.

all the boundarylayer are coming together at one line. this is giving me a not wanted result when i run pimpleFoam.

Is there any Option to turn this behaviour off?

greeting draufunddran

seadmiral March 3, 2012 22:34

I know this is an old post, but I ran across it (and others) today with the same problem.

My solution was to play with featureAngle in the addLayersControls parameters of snappyHexMesh. I decreased this angle to 30 degrees and the resulting boundary layer mesh no longer extended all the way to the TE.

Artur July 9, 2013 05:20

Like the previous poster, I ran across this old post and thought I'd post a reply as well.

I've found that replacing a sharp trailing edge feature with one with a small radius leads to a much better mesh snap and layer addition.

Of course, the feature angle mentioned previously is also a key parameter.

Paolo.F September 20, 2013 09:36

Hallo everyone,
I'm also having some problems meshing a NACA0010...I've tried to work with the FeatureAngle and i've also replaced the sharp edge with a small radius, but it isn't still ok...any other idea?!

Anyway, I've tryed to start a simulation with simpleFoam...everything works fine till the end, but when i try to watch the results with paraView I get this error message:


size 0 is not equal to the given value of 166400

file: /home/paolo/TESI/Lungo/soluzioni/ultimo/3/U.boundaryField.NACA from line 1551485 to line 1551486.

    From function Field<Type>::Field(const word& keyword, const dictionary&, const label)
    in file /home/opencfd/OpenFOAM/OpenFOAM-2.2.1/src/OpenFOAM/lnInclude/Field.C at line 236.

FOAM exiting

It seems that the problem is in the boundary file; I can see that I have 8 Boundary conditions, and that two of them are on the NACA. The last one ha 0 faces but I don't know how to handle the problem...


/*--------------------------------*- C++ -*----------------------------------*\
| =========                |                                                |
| \\      /  F ield        | OpenFOAM: The Open Source CFD Toolbox          |
|  \\    /  O peration    | Version:  2.2.1                                |
|  \\  /    A nd          | Web:                      |
|    \\/    M anipulation  |                                                |
    version    2.0;
    format      ascii;
    class      polyBoundaryMesh;
    location    "3/polyMesh";
    object      boundary;
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //

        type            patch;
        nFaces          4000;
        startFace      4647766;
        type            patch;
        nFaces          4000;
        startFace      4651766;
        type            symmetryPlane;
        inGroups        1(symmetryPlane);
        nFaces          10298;
        startFace      4655766;
        type            symmetryPlane;
        inGroups        1(symmetryPlane);
        nFaces          10298;
        startFace      4666064;
        type            symmetryPlane;
        inGroups        1(symmetryPlane);
        nFaces          3200;
        startFace      4676362;
        type            wall;
        nFaces          3200;
        startFace      4679562;
        type            wall;
        nFaces          166400;
        startFace      4682762;
        type            wall;
        nFaces          0;
        startFace      4849162;

// ************************************************************************* //

Can anyone help me?

Artur September 22, 2013 03:52

Try removing the empty boundary condition, either by manually editing the boundary file or by running the following:

createPatch -overwrite
See if that helps with removing the error message...

Paolo.F September 23, 2013 06:24

Hi Artur,
thanks a lot for you reply!

Do you mean I should edit the boudary file before starting the simulation?

At the moment I have 2 simulations running:

One with the boundary file edited, and the other one non-edited ( i'll chenge it at the end)

I hope I can see something in a few hours...

Artur September 23, 2013 15:50

I think it would be best to do this right after the meshing process as having two BC's for the same patch might make the solver do some hard to predict thing, I imagine.

Paolo.F September 25, 2013 04:13

Hi Artur!
Thanks for your hints!!! I've just finished my simulation and it worked properly!
Now I just need to refine the mesh to get better results...


miro2000 October 1, 2013 17:13

Regarding trailing edge boundary layer, from my experience It's difficult to obtain better results. I found It's helpful to introduce some refinement in the trailing edge.
One can do that via surface refinement or via volume refinement. I've used surfaceref. but vol version is easier to implement but it creates more cells, so if your mesh is small and not already very refined, that's a place to start.
Let my know if you get stuck

potentialFoam April 12, 2016 04:41

Good mesh - bad mesh
Dear Foamers,

seems there are still problems for snappy dealing with layers at the trailing edge of a foil.

I achieved this trailing edge and I am already quite proude of the result:

Although the layers look beautiful, they all end up in ONE cell which is complete nonsense. How can I improve this?
edit: (Here, layers are added at all patches except at the patch that belongs to the trailing edge surface.)

Refinement with snappy afterwards is not possible, because 'this' cell is no hex-type cell but consists of more than 8 nodes.

Before layer addition, the mesh looks like:

If the mesh at the trailing edge is refined before layer addition, layers are not extruded (this is a common 'error' for me...):

Its a NACA profile, I use OF301 with block mesh first and snappy afterwards.

LVDH June 12, 2016 10:38


I am currently struggling as well.

The top image you posted could be just a bad choice of cutting plane. Is it possibly a symmetry or bounding plane of the domain?
Try a few mm in span-wise direction. It might look better then.

If it looks good, maybe you could then share your settings.


potentialFoam June 13, 2016 07:08

Dear André,

thanks for your hint. Unfortunately, the result is the same along the spanwise direction.
I switched to another meshing tool. But nevertheless I would be happy to find a solution for the issue metioned above.


LVDH June 13, 2016 07:11

Well as long as shm is involved there never seems to be a simple solution.

OF v30+ is better at creating surface layers so it might be an easy fix.
The main issue I see with the v3+ shm version is that it seems to have problems when you have cell zones. So as long as you are only meshing wings it is worth a try.

All times are GMT -4. The time now is 12:45.