CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Native Meshers: snappyHexMesh and Others (
-   -   snappyHexMesh decomposition error (

johnsmith332 February 27, 2012 02:16

snappyHexMesh decomposition error
Hi, I'm pretty new at OpenFOAM and I'm trying to so a dsmcFoam simuation using a mesh created with snappyHexMesh. The mesh looks fine in ParaView but I get warnings when I run dsmcInitialise, and the same warnings when I run the simulation which cause it to crash. The error says:

--> FOAM Warning :
From function Foam::List<Foam::FixedList<Foam::label, 4> >Foam::Cloud<ParticleType>::faceTetIndices(label fI, label cI) const
in file meshes/polyMesh/polyMeshTetDecomposition/polyMeshTetDecomposition.C at line 561
No base point for face 25085, 3(3298 2596 2567), produces a valid tet decomposition.

Another warning says:

No base point for face xxxxx, (xxxx)produces a decomposition that has a minimum volume greater than tolerance

I've looked all over the place trying to figure out what's causing this error but with no luck. Does anyone know what this error means or how I might fix it?

e.ahmadiyan April 8, 2013 02:53

Hi dear johnsmith332
I have same problem as you too. Could you help me to resolve it.
Thanks in advance.
Best regards.


jackeyhust June 25, 2013 11:33

hi, Esmaeil and John,

have you found the way to solve this problem above? Could you give me a hint for it ? thank you!

best regards,


Ramsky July 29, 2013 09:57

Looks like the problem is with face tets.

If your mesh is generated with snappyHexMesh, try the following:

In snappyhexMeshDict file, look for "minTetQuality".

//- Minimum quality of the tet formed by the face-centre
// and variable base point minimum decomposition triangles and
// the cell centre. Set to very negative number (e.g. -1E30) to
// disable.
// <0 = inside out tet,
// 0 = flat tet
// 1 = regular tet

For a regular tet, it should be positive. Try setting it to 1. If it does not work, set it to a very low positive number. Say 1e-10.

One way to check whether the issue with face tet is resolved or not before the start of the simulation is to do an "checkMesh -allGeometry". It will report if there are any issues with face tets.

Hope this helps.


manuelffonseca April 7, 2017 22:56

hi, have you used first the blockmesh command? i had the same error and it was because i forgot to execute the blockmesh...

All times are GMT -4. The time now is 19:50.