CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Mesh Utilities (
-   -   MapFields seems hanging (

Fire2fly April 23, 2013 10:28

MapFields seems hanging
For a grid convergence study I am trying to map the fields from a coarse mesh to a finer mesh with MapFields. MapFields seems however hanging at the statement:

Create databases as time

Source time: 0
Target time: 0
Create meshes

Source mesh size: 366539        Target mesh size: 461702

Both -consistent and with a mapFieldsDict file does not work. The patches for both cases are exactly the same, except for one patch that is generated by snappyHexMesh which could locally be a little bit different. Could that be a problem?

hanness May 3, 2013 05:45


I came across the same problem and was able to narrow it down a little bit. Using blockMesh as mesh generator everything works fine as long as only orthogonal cells are refined. Moreover, as long as I refine the mesh along the direction of one of the coordinate axes everything is fine also for nonorthogonal cells. However, I've got cells in the boundary layer with very high aspect ratios (~600) and I would like to refine the mesh in the direction of the wall (which is inclined) and that does not work anymore.
I also tried to use mapFields with the option -mapMethod mapNearest in order to overcome any potential problem with the interpolation but it still does not work.

Anybody any idea?

Best regards

jaason June 2, 2014 17:19

I've been having issues with OF230 mapfields command as well,
it meshes and the fields look absolutes fine but I end up getting errors when I run the solver,
are you saying that your will not even finish the mapfields proceedure?

All times are GMT -4. The time now is 23:09.