CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Mesh Utilities (
-   -   SnappyHexMesh not generate mesh first time (

mavimo August 24, 2008 06:43

Hi, I test snappyHexMesh with
Hi, I test snappyHexMesh with tutorial and work fine, after that I'm starting to test it with another object into domain.

Mesh generation
On web I find a diablo *.lwo model, with blender i generate stl (using script posted by Andrew Kink ad address ).
After first stl generation i check stl with admesh and using it to correct error on mesh and move it; now I have my correct STL model.

Case setting
After STL creation I genereate a simple domain with blockMesh (no boundary specs, now I'm just check mesh creation), and write my /system/snappyHexMeshDict where I specificate info for mesh creation (see link on bottom for complete case)

Problem description
If I run snappyHexMesh it fall after some step, and not complete the mesh generation. I try to enable debug function into snappyHexMeshDict (debug = 1) and it write mesh for time 2 and 3, and after still fails, but if I restart snappyHexMesh after first time (if debug = 1) it complete mash generation without problem (start from last time step write on case directory)

I test it with different mesh refinement, and into every case error occur (on different time step for every case, in accord with mesh refinement specs).

Case download:
You can find my case (with stl generate and correct) on address:

Run it:
tar -xzf diablo.tar.gz
blockMesh -case diablo
checkMesh -case diablo
snappyHexMesh -case diablo # error (write some time step)
snappyHexMesh -case diablo # generate emsh

Someone can explain me where's my error? Why if first time fall after work fine? I think problem is on saving data, after saving some info change (approximate points position?) and when restart work fine.

Thanks in advance


PS. sorry for my bad english :P

mavimo August 24, 2008 14:44

other info I use OpenFOAM 1.5
other info
I use OpenFOAM 1.5 32bit on AMD 1.7GHz / 512MB ram with Linux Ubuntu 8.04.
Alberto P write me this case work fine with OF1.5 64bit

jfb August 25, 2008 17:16

Same problem here: openSUSE 1
Same problem here:
openSUSE 10.3 on Sun Ultra M2 (64bit) with OpenFOAM 1.5 patched: runs fine
openSUSE 10.3 on IBM T43p (32bit) with OpenFOAM 1.5 patched: same behaviour as mentioned by Marco Moscaritolo

mattijs August 26, 2008 04:14

I ran your case in 64 bit and
I ran your case in 64 bit and 32 bit mode. Both meshing runs complete without problems.

Why do you have minimum pyramid volume set to 1e-3? This is quite a large value compared to the cell volumes so leaves very little scope to the snapper to morph to your surface.

mavimo August 26, 2008 07:08

@Mattijs: this is a sample to
@Mattijs: this is a sample to study snappyHexMesh tool, this mesh is not a fine mesh (I have other snappyHexMeshDict with param for fine mesh), but my primary problem is into mesh creation error.


All times are GMT -4. The time now is 00:08.