CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Meshing & Mesh Conversion (
-   -   Generating multiple internal walls using gmshToFoam (

rendagar September 30, 2013 10:40

Generating multiple internal walls using gmshToFoam
Hello fellow CFD enthusiasts,

I've been banging my head against a problem for a couple of days now and am hoping someone can help me.

First let me give you an idea of what I would like to simulate. The basic idea is a simple rectangular box with 2 separate fans inside, not connected to the wall. To start with I would like to solve the (incompressible) flow inside the box at different fan speeds.

The problem I have is that when I generate a mesh file using
gmsh which has internal geometries (i.e. the fans) they are lost after I convert the file using the gmshToFoam tool. I have read a couple of (older) posts about this problem however the solutions they post only work for converting a single boundary, which is not enough.

This old post comes close to that I require. It instructs you to make a number of changes to the boundary file and files in 0/ and to repeat this process for all patches. I can make the process work once but than all information regarding the not yet converted internal patches is lost and the face indexes are recalculated, so I can't add them. A possible cause is that I am missing the faceSet command however I have been unable to locate the command or that it is supposed to do. All my tries so far have been with the .geo file provided in the post above and have been unsuccessfully (for multiple patches, a single patch is no problem).

This post is a bit more recent but describes the same process and also fails on multiple faces.

A possible solution (found in would be however I don't know how to compile this. I have extracted the file to /opt/OpenFOAM-2.2.1/applications/utilities/mesh/manipulation and tried to use wmake to compile it. However when I try to use wmake it complains that the environment variable $WM_OPTIONS is not set. I believe that is incorrect because ">>echo $WM_OPTIONS" returns "linux64GccDPOpt". I don't know it that is correct but WM_OPTIONS is certainly is set to something.

If anyone solved this problem, knows of a better approach to generating a mesh with internal structures (using non commercial software) or what the problem with wmake is, I would very much appreciate your input.


acahuzac October 13, 2014 02:20

Same issu in OpenFoam 2.3.0. Please, some help ?

acahuzac October 20, 2014 03:56

The only solution I found, and which works quite well, is to make distinct meshes with Gmsh, and then merge them with "mergeMeshes". A bit tedious, but at least it works fine.

All times are GMT -4. The time now is 03:32.