CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Meshing & Mesh Conversion

[snappyHexMesh] locationInMesh not working?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   September 17, 2016, 02:31
Default locationInMesh not working?
  #1
New Member
 
Matt Koch
Join Date: Sep 2016
Posts: 2
Rep Power: 0
mattkoch is on a distinguished road
Hello,

I have spent fairly massive amounts of time trying to understand blockMesh and snappyHexMesh. I am trying to mesh the interior of a performance theatre for air flow calculations. Attached are the STL, blockMeshDict and and snappyHexMeshDict files of a highly simplified version. Also attached is the Model.hdf file for Salome, where I created the original model and STL files.

I am fairly certain that my locationInMesh is pointing to the interior, but when I run this case using simple blockMesh and snappyhexMesh commands (no other arguments), my mesh shows BOTH the interior AND exterior regions on paraFoam. I must be doing something wrong, but what?

Thanks,

Matt Koch
Attached Files
File Type: zip Theatre.zip (10.3 KB, 2 views)
File Type: zip Model.hdf.zip (9.5 KB, 2 views)
mattkoch is offline   Reply With Quote

Old   September 17, 2016, 16:45
Default probably an STL problem!
  #2
New Member
 
Matt Koch
Join Date: Sep 2016
Posts: 2
Rep Power: 0
mattkoch is on a distinguished road
So, I woke up this morning thinking "Didn't I read about STL quality problems somewhere when learning about snappyHexMesh?". I did a quick web search, and sure enough I found that using Salome STL files generated from its GEOMETRY module are of very poor quality. Instead, it was recommended to generate STL files from Salome's MESH module. So, I generated surface meshes there and exported these. Low and behold, that seems to have led to success, at least for the case I posted yesterday. The new STL files are much too big to attach, though.
mattkoch is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
findCell() in parallel: not working if location is outside the domain TobiWol OpenFOAM 0 January 10, 2018 15:33
Processor 0 not working vishwesh OpenFOAM Running, Solving & CFD 0 November 17, 2017 04:35
Is the subsetMotionSolver working in parallel? Arnoldinho OpenFOAM Running, Solving & CFD 7 April 27, 2016 05:38
DPM parallel is not working but serial is working johnwinter FLUENT 1 March 27, 2012 03:01
Working directory mgonzalo FLUENT 1 November 11, 2011 11:05


All times are GMT -4. The time now is 17:30.