CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Meshing & Mesh Conversion

[snappyHexMesh] Flange Tutorial Issue

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 2 Post By jpjamo

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   February 5, 2020, 19:30
Default Flange Tutorial Issue
  #1
New Member
 
Carl Reilly
Join Date: Aug 2010
Posts: 25
Rep Power: 14
carl_r is on a distinguished road
Hi,
I'm trying to learn to use snappyHexMesh, so am trying to complete the flange tutorial. I'm using OpenFOAM v7

I have run into an issue I can't solve.

The steps I undertake are:
1) copy tutorial directory and stl file to my run directory

Code:
cp -r $FOAM_TUTORIALS/mesh/snappyHexMesh/flange .
Code:
cp -r $FOAM_TUTORIALS/resources/geometry/flange.stl.gz .flange/constant/triSurface
2) Move to the tutorial directory
3) Run blockMesh
4) Try to run surfaceFeatureExtract, however I get the following error:

HTML Code:
--> FOAM FATAL ERROR:
cannot find file "/home/carl/OpenFOAM/carl-7/run/flange/system/surfaceFeatureExtractDict"
In the systems directory there is a surfaceFeaturesDict, but not a surfaceFeatureExtractDict. Has the name changed in the new version, or does anyone know why i'm getting this error?
carl_r is offline   Reply With Quote

Old   April 28, 2022, 11:59
Default same issue
  #2
New Member
 
James
Join Date: Apr 2022
Posts: 2
Rep Power: 0
jpjamo is on a distinguished road
Hi All,

new openFoam user going through lots of tutorials and I have also got stuck on the Flange Tutorial 12.
Everything I have read says that the STL file should be copied into the /constant/trisurface folder, yet this tutorial only works if the flange.stl file is located in the /constant/geometry folder.

There is an Allrun script that comes with the tutorial and it even specifies this constant/geometry folder location.

I have tried doing it "manually" without the Allrun and unless I put the STL in /constant/geometry folder it throws up the same error when I run the surfaceFeatures function or snappyHexMesher.

I am running v9 on Windows and everything else has run/loaded fine to this point.

Many thanks in advance!
James
jpjamo is offline   Reply With Quote

Old   April 29, 2022, 10:13
Default Aha!
  #3
New Member
 
James
Join Date: Apr 2022
Posts: 2
Rep Power: 0
jpjamo is on a distinguished road
Hello All,

well I found the issue.

See the following commit link:

https://github.com/OpenFOAM/OpenFOAM...6c91da2a915dec

So /constant/geometry is the new standard location for any geometry files but a triSurface sub-folder can still be used. My issue was that I had both the geometry and triSurface folders located in the \constant folder, however geometry was empty which it doesn't like.
As soon as I deleted the empty geometry folder, everything works as per the old tutorial references.

Just for anyone's future reference to avoid a wasted day following up a detail that shouldn't matter

cheers
James
snak and AtoHM like this.
jpjamo is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
BC issue for chtMultiRegionFoam Aadhavann OpenFOAM Running, Solving & CFD 1 July 19, 2019 02:00
waveDyMFoam stability issue goodster OpenFOAM Running, Solving & CFD 6 September 23, 2018 04:40
help with 3D Bifurcating Artery tutorial - no wall shear seen 9aul FLUENT 0 January 15, 2018 18:20
Dam break tutorial - transportProperties issue Guimloute OpenFOAM Running, Solving & CFD 4 June 27, 2017 11:52
[Tutorials] New Dakota - OpenFOAM Coupling Tutorial Tobi OpenFOAM Community Contributions 0 October 9, 2016 17:19


All times are GMT -4. The time now is 06:52.