CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Meshing & Mesh Conversion

[mesh manipulation] The extracted patch Labels in not proper for different test case.

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 31, 2021, 03:08
Default The extracted patch Labels in not proper for different test case.
  #1
Member
 
Sunag R A
Join Date: Jul 2019
Location: Bangalore, India
Posts: 63
Rep Power: 4
sunagra27 is on a distinguished road
Dear All,


Here I have a peculiar case where I am confused on how to clear the error from this. Below I am writing step-by-step process of my test case along with images present. Please let me know any possible leads.


1. I am working with chtMultiRegionSimple Foam for heat conduction. I am working for many test cases, so I am using pyFoam for automation. The mesh for each test case looks similar with little coordinate changes.


2. The mesh has two patches. One bottom and 2nd the surface. The surface Patch is divided into two boundary conditions (One for fixed temp BC from external file and other for convection) using PatchToFace and LabelToFace topoSet utility.


Below is the topoSet utility for the same.


Code:
actions
(

 {
    name    patchface;
    type    faceSet;
    action    new;
    source    patchToFace;
    sourceInfo
    {
        name "finalmesh_36_right.stl";
    }
    }

    {
    name    faceID_patch;
    type    faceSet;
    action    new;
    source    labelToFace;
    sourceInfo
    {
    value
        (
        #include "faceID_data"
        );
    };
    }

);

3. Here the "faceID_data" is the splitted faces of the convection BC from the labels obtained from "patchface" faceSet. So that the patch is splitted into convection and fixed BC.



4. The problem what I am facing now is such that for few test cases, once the topoSet is run, the alignment of faceID_patch labels is run is not properly arranged which is causing a problem simulation and in visualization. This is happening for only few test cases.


5. Below I have attached the link of different images.


Images:

a. Complete surface mesh:


https://drive.google.com/file/d/1bFY...ew?usp=sharing


b. FaceID_patch after splitting ( This is proper alignment for mesh splitting):


https://drive.google.com/file/d/11Vm...ew?usp=sharing


c. FaceID_patch after spliitng (This for few test cases where alignment is not proper):


https://drive.google.com/file/d/12B8...ew?usp=sharing


I am particularly worried after "c" in the links because it has to align like "b" in links. Why does it happen and how to overcome it.? Any leads will be appreciated.

Thanks,


Sunag R A.
sunagra27 is offline   Reply With Quote

Reply

Tags
mesh, openfoam, paraview, toposet, visualization

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[DesignModeler] DesignModeler Scripting: How to get Full Command Access ANT ANSYS Meshing & Geometry 53 February 16, 2020 15:13
y+ and u+ values with low-Re RANS turbulence models: utility + testcase florian_krause OpenFOAM 113 June 25, 2019 00:58
Is Playstation 3 cluster suitable for CFD work hsieh OpenFOAM 9 August 16, 2015 14:53
createPatch Segmentation Fault (CORE DUMPED) sam.ho OpenFOAM Pre-Processing 2 April 21, 2014 02:01
Problem with rhoSimpleFoam matteo_gautero OpenFOAM Running, Solving & CFD 0 February 28, 2008 06:51


All times are GMT -4. The time now is 01:28.