CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Meshing & Mesh Conversion

[blockMesh] Binary mode donbt work

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   September 14, 2005, 04:53
Default Binary mode donbt work
  #1
Member
 
Fabian Peng Karrholm
Join Date: Mar 2009
Posts: 61
Rep Power: 13
fabianpk is on a distinguished road
I have a bit of a strange problem with OpenFOAM 1.2. When I have a mesh or a saved solution that's been saved in binary format, I can't use it for restarting the case or postprocessing with ParaFoam.
It doesn't matter if it's a mesh generated in gambit and converted, or if it's generated with blockMesh. It only works if I use the ascii format.

I get this message:

--> FOAM FATAL IO ERROR : Expected a ')' while reading binaryBlock, found on line 29 an error

file: ../refnozzleLES.ver12.schemetest/0.00204928/nuSgs at line 29.

From function Istream::readEnd(const char*)
in file db/IOstreams/IOstreams/Istream.C at line 111.




What have I done wrong?

/Fabian
fabianpk is offline   Reply With Quote

Old   September 14, 2005, 04:58
Default Just out of interest, are you
  #2
Senior Member
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,419
Rep Power: 22
mattijs is on a distinguished road
Just out of interest, are you running with compression and if so what happens if you switch off compression?
mattijs is offline   Reply With Quote

Old   September 14, 2005, 04:59
Default Hmm, I've been using binary wi
  #3
Senior Member
 
Hrvoje Jasak
Join Date: Mar 2009
Location: London, England
Posts: 1,871
Rep Power: 29
hjasak will become famous soon enough
Hmm, I've been using binary without problems a few days ago; however, compressed binary did not work. Did you use compression of the files (i.e. .gz extension on nuSgs)?

Hrv
__________________
Hrvoje Jasak
Providing commercial FOAM/OpenFOAM and CFD Consulting: http://wikki.co.uk
hjasak is offline   Reply With Quote

Old   September 14, 2005, 05:03
Default Yes, I always do. However, now
  #4
Member
 
Fabian Peng Karrholm
Join Date: Mar 2009
Posts: 61
Rep Power: 13
fabianpk is on a distinguished road
Yes, I always do. However, now I just noticed that it works if I turn off compression. Does Foam 1.2 use a new version of gzip?

/Fabian
fabianpk is offline   Reply With Quote

Old   September 20, 2005, 11:27
Default Hi Fabian, can you post thi
  #5
Senior Member
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,419
Rep Power: 22
mattijs is on a distinguished road
Hi Fabian,

can you post this as a bug?
mattijs is offline   Reply With Quote

Old   May 21, 2006, 12:17
Default Can anyone post the fix of thi
  #6
Senior Member
 
Maka Mohu
Join Date: Mar 2009
Posts: 305
Rep Power: 14
maka is on a distinguished road
Can anyone post the fix of this bug. I'm still using V 1.2. Thanks.

Kind regards,
Maka
maka is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[PyFoam] Problems with the new PyFoam release zfaraday OpenFOAM Community Contributions 13 December 9, 2014 19:58
[PyFoam] having problems with pyfoam Installation vitorspadetoventurin OpenFOAM Community Contributions 3 December 2, 2014 08:18
Grid Check Fails in Parallel Processing Mode askance Main CFD Forum 0 October 20, 2010 11:11
ATTENTION! Reliability problems in CFX 5.7 Joseph CFX 14 April 20, 2010 16:45
Sliding mesh error Karl Kevala FLUENT 4 February 21, 2001 16:52


All times are GMT -4. The time now is 07:07.