CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Meshing & Mesh Conversion (
-   -   motorbike tutorial error in snappy hex (

mihaipruna March 7, 2012 10:33

motorbike tutorial error in snappy hex
I tried to run the tutorial using allrun.
i get the following error:

Running snappyHexMesh on /opt/OpenFOAM/OpenFOAM-2.0.x/tutorials/incompressible/simpleFoam/motorBike
/opt/OpenFOAM/OpenFOAM-2.0.x/bin/tools/RunFunctions: line 37: 5698 Killed $APP_RUN $* > log.$APP_NAME 2>&1

I attempted the STL file cleanup from here and replaced the file with the new stl file, still getting the error

Please help. thank you!

wyldckat March 7, 2012 11:43

Greetings Mihai,

You've skipped the very first step from the tutorials guide:


mkdir -p $FOAM_RUN

You should work on a copy of the tutorials, not work directly on the original tutorials folder ;)

Best regards,

mihaipruna March 7, 2012 14:36

oops thanks, I forgot about that step :)

mihaipruna March 7, 2012 21:29

ok, I copied to $FOAM_RUN, same error. Even tried a different stl file.
I'm using the OpenFOAM packaged with GeekoCFD

wyldckat March 8, 2012 05:31

Hi Mihai,

Mmm... OK, try getting the latest one from the snapshot link at the top left on this page:

By the way, does the file "log.snappyHexMesh" get created? If so, what's the error message it shows inside it?

If this also fails, perhaps you've got to complain to Alberto ;)
Wow, GeckoCFD 3.0 is now available as well:

Best regards,

mihaipruna March 8, 2012 16:27

I did a fresh OF install on Ubuntu and it works now.

All times are GMT -4. The time now is 11:25.