CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Meshing & Mesh Conversion (
-   -   Discretizer "Run blockmesh" issue (

cfdone March 9, 2012 16:17

Discretizer "Run blockmesh" issue
Hi there, I recently finished the basic openfoam cavity tutorials from the docs as well as ran a few of the examples and I feel as though I'm ready to start working with my own geometry.

To keep my first proof of concept simple I chose Discretizer as my meshing software because I found this helpful golf ball tutorial on there site:

I created a very simple sphere with the same dimensions as the golf ball and followed the tutorial exactly (even using the same blockmesh dimensions).

My problem is no matter what .stl file I use (I dl'd others), or how big I make my blockmesh domain, when I go to Run>>Run blockMesh it is grayed out.

As I said before, I have copied the process and dimensional values of the tutorial exactly so I'm just stumped why its not even giving me the option.

I ran blockmesh in the directory through terminal and it seemed to work but when I tried to then use snappy I received errors. Any ideas why I'm not getting the blockmesh option..or snappyhexmesh option for that matter?

Also, I am extremely new to this whole thing (installed ubuntu 3 days ago and haven't stopped messing with this stuff since). If you have any opinions on if I should even be using discretizer at all let me know. I wouldn't mind looking at alternatives.


cfdone March 10, 2012 11:49

Figured it out. I was double clicking the .sh and using "run in terminal" instead of opening terminal and ./ I thought using the "run in terminal" was equivalent to running the script directly but of course I was wrong.

dumb mistake please delete this thread.

All times are GMT -4. The time now is 15:05.