CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   ParaFoam over SSH - cannot connect to X server (

uli July 17, 2012 18:03

ParaFoam over SSH - cannot connect to X server
hi all

Running a simulation over ssh works, but when I type "paraFoam" it gives me


cannot connect to X server
I use opensuse 11.4, the server I am connected to has ubuntu.

I also set up a connection with XMing and Putty on Windows, there it works.

Any suggestions?


mturcios777 July 17, 2012 19:31

What command are you running to connect to your server? First thing I would make sure is that X forwarding is allowed. You have the -X/-Y option in your command to enable X forwarding?

uli July 19, 2012 17:54

hi Marco, thanks for your reply.

Sorry, my bad. I forgot the -X.

But it gives me another error:


ssh -X myname@ipadress
and when I run "paraFoam" in the case-directory the "welcome" Window of ParaView opens but after a few seconds I get


created temporary 'cavity.OpenFOAM'
Segmentation fault (core dumped)


mturcios777 July 19, 2012 18:16

It seems like X forwarding is working as you got the welcome screen. Does this happen with both -X and -Y options?

wyldckat July 20, 2012 05:15

Greetings to all!

This comes to mind:

Originally Posted by preichl (Post 279104)
I had similar errors when connecting via ssh to the machine running paraview (even with paraview 3.8.1).

Setting the environment variable via the command below worked for me.


I tried this after reading

Hope this helps anyone else in the same boat.

Best regards,

All times are GMT -4. The time now is 09:08.