CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Problem running paraview (libQVTK?) (

t_clark July 31, 2012 07:43

Problem running paraview (libQVTK?)
Hi All,

I experience the following problem when trying to run OpenFOAM-ParaView, which was installed from the OpenCFD RPM, in openSUSE 12.1...

gtt@deepthought:~> paraview
/opt/OpenFOAM-ParaView-3.12.0/lib/paraview-3.12/paraview: symbol lookup error: /opt/OpenFOAM-ParaView-3.12.0/lib/paraview-3.12/ undefined symbol: _ZN19QAbstractProxyModel11setItemDataERK11QModelIn dexRK4QMapIi8QVariantE

I tried installing paraview 3.14 from the science repository - that works just fine, but doesn't have the openFOAM reader plugin.

I did ldd -d paraview (on the faulty 3.12 version), and it shows:
ldd -d paraview => (0x00007fffb88c2000) => /lib64/ (0x00007f5c9591c000)
/lib64/ (0x00007f5c95cab000)

Does anyone know of either an RPM of Paraview 3.14 which has the openFOAM reader built in, or know how I can resolve the above problem?

Cheers for any help!


wyldckat July 31, 2012 17:09

Greetings Thomas,

A couple of questions:
  1. Did you run:

    zypper in libqt4 libQtWebKit4
  2. Is your openSUSE 12.1 fully up-to-date?

As for an RPM of ParaView 3.14: there is no need to use an RPM. From here "Related issues to ParaView with OpenFOAM - Fixes and solutions", you can find these instructions: Using the official pre-built ParaView 3.10.1 version with OpenFOAM
It should be easy enough to adapt to the latest OpenFOAM and ParaView versions.

Nonetheless, if you only want an RPM, openSUSE's science repo has got 3.14.0:

Best regards,

t_clark August 8, 2012 05:23

Hi Bruno,

Thank you for your help.

I had done that, but your mention of an update made me think... So I checked my repositories; I was using the development (unstable) repositories for suse - I disabled them, then did an update - which reverted me back to consistent QT libraries. Problem solved.

Best regards and thanks again,


All times are GMT -4. The time now is 01:02.