CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Trouble running paraFoam in cavity tutorial

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By alexeym

Reply
 
LinkBack Thread Tools Display Modes
Old   October 10, 2014, 15:28
Default Trouble running paraFoam in cavity tutorial
  #1
New Member
 
Sofy
Join Date: Oct 2014
Posts: 6
Rep Power: 4
sweisenb is on a distinguished road
Hello,

I am new to OpenFOAM. I recently installed OpenFOAM 2.3.0 on a Ubuntu 14.04 OS, and am trying to go through the first standard "cavity" case file.

In attempting to visualize the mesh in ParaView, I was able to open the GUI by typing "paraFoam" in the terminal under the case directory. However, the following errors popped up, and I was not able to visualize the mesh:

p, li { white-space: pre-wrap; } ERROR: In /home/sweisenb/OpenFOAM/OpenFOAM-2.3.0/applications/utilities/postProcessing/graphics/PV4Readers/PV4FoamReader/PV4FoamReader/vtkPV4FoamReader.cxx, line 216
vtkPV4FoamReader (0x320b360): could not find valid OpenFOAM mesh


ERROR: In /home/sweisenb/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Common/ExecutionModel/vtkExecutive.cxx, line 754
vtkPVCompositeDataPipeline (0x336c820): Algorithm vtkPV4FoamReader(0x320b360) returned failure for request: vtkInformation (0x33a5230)
Debug: Off
Modified Time: 90100
Reference Count: 1
Registered Events: (none)
Request: REQUEST_INFORMATION
ALGORITHM_AFTER_FORWARD: 1
FORWARD_DIRECTION: 0


ERROR: In /home/sweisenb/OpenFOAM/OpenFOAM-2.3.0/applications/utilities/postProcessing/graphics/PV4Readers/PV4FoamReader/PV4FoamReader/vtkPV4FoamReader.cxx, line 216
vtkPV4FoamReader (0x320b360): could not find valid OpenFOAM mesh


ERROR: In /home/sweisenb/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Common/ExecutionModel/vtkExecutive.cxx, line 754
vtkPVCompositeDataPipeline (0x336c820): Algorithm vtkPV4FoamReader(0x320b360) returned failure for request: vtkInformation (0x33a5230)
Debug: Off
Modified Time: 90100
Reference Count: 1
Registered Events: (none)
Request: REQUEST_INFORMATION
ALGORITHM_AFTER_FORWARD: 1
FORWARD_DIRECTION: 0


If anyone has encountered this before or has a way to fix it, I would be grateful. I am new to programming and to working with opensource software, so please elaborate...

Thank you!
sweisenb is offline   Reply With Quote

Old   October 10, 2014, 15:51
Default
  #2
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 1,438
Rep Power: 25
alexeym will become famous soon enoughalexeym will become famous soon enough
Hi,

it seems you've forgotten to generate mesh with blockMesh utility.
sweisenb likes this.
alexeym is offline   Reply With Quote

Old   October 10, 2014, 15:56
Default
  #3
New Member
 
Sofy
Join Date: Oct 2014
Posts: 6
Rep Power: 4
sweisenb is on a distinguished road
Thank you alexeym, looks like I overlooked that important step...

I appreciate you posting the reply so quickly!
sweisenb is offline   Reply With Quote

Reply

Tags
cavity, error, parafoam, tutorial

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
License trouble: ANSLIC_ADMIN, FLEXlm not running, but two lmgrd processes running! dancoz87 ANSYS 17 November 14, 2016 02:10
Running paraFoam as a parallel job Hisham OpenFOAM Paraview & paraFoam 2 September 13, 2011 09:14
Statically Compiling OpenFOAM Issues herzfeldd OpenFOAM Installation 21 January 6, 2009 10:38
ParaFoam problem with cavity case roger OpenFOAM Paraview & paraFoam 9 September 16, 2008 22:00
Tutorial is not running on star-CD version 3.2 Arnab CD-adapco 0 August 30, 2004 15:43


All times are GMT -4. The time now is 02:59.