CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   ParaFoam error in OpenFOAM15 (

asaha July 15, 2008 09:57

Hello, I get the following

I get the following error when using paraFoam with icoFoam tutorial.
Failed to initialize TTM buffer manager. Falling back to classic.
terminate called after throwing an instance of 'std::length_error'
what(): basic_string::_S_create
/asaha/OpenFOAM/OpenFOAM-1.5/bin/paraFoam: line 83: 5624 Aborted paraview --data=$caseFile

I am using the binary version of the OpenFOAM-1.5 package. Pl. help to resolve this.


A Saha.

louisgag July 15, 2008 18:19

Have you tried compiling the p
Have you tried compiling the paraview and PV3FoamReader on your machine? I had to compile them myself even if my qt4 version was the proper one.

srinath July 15, 2008 23:01

Hello I installed the right

I installed the right version of qt-4.3.2 on Ubuntu 7.10
I am using the binary version of openFoam
when i invoke paraFoam, it asks me to choose a appropriate reader from a big list.

I choose openFoam files as the type.
But i get the following error after it crashes out

terminate called after throwing an instance of 'std::length_error'
what(): basic_string::_S_create
Aborted (core dumped)

Pls help me resolve this


louisgag July 15, 2008 23:17

even with "the right version o
even with "the right version of qt-4.3.2 on Ubuntu 7.10 " you still have to compile the two packages I mentionned above to get rid of that error message.

To compile paraview you will need to install a library, the output of the compiler will tell you which one. That library is available under ubuntu 7.10 package manager (get the lib...-dev).

hope this helps

srinath July 16, 2008 00:50

Thanks Louis I compiled par
Thanks Louis

I compiled paraview3.3 and PV3FoamReader. Now it doesn't crash out.
I didn't have to install any new library. Maybe i had it already.

However the menu seems different. I hope that it works ok, as i seem to get only the mesh and not the solution, even though i click on the variable that should be displayed, time instant etc


asaha July 16, 2008 00:52

Compiling the paraview and PV3
Compiling the paraview and PV3FoamReader in my machine has resolved the issue. But it crashes a few times. I will report specifically with details.

srinath July 17, 2008 03:44

Hello everyone I have a str
Hello everyone

I have a strange problem with paraFoam
I go into a case directory(say cavity) and invoke paraFoam.
In the object inspector i see 3 tabs,
properties, display and information.

1)I see the fields p and U in properties, along with various grid specific details, like displaying patches etc. In the information tab, i see all the time directories.

2)I select p and internal mesh in properties, and a particular time directory and choose gourad interpolation.

3)But yet all i see is the internal mesh.

No error message gets displayed in the command window.

Am i missing something trivial?

louisgag July 17, 2008 08:58

Srinath, did you change the

did you change the default "solid color" option? That might be your problem,,, The new paraview is different so you have to play around a bit to get used to it.

srinath July 17, 2008 11:05

Hi Louis In the display tab
Hi Louis

In the display tab, i have a field which says color by

The options presented to me are
solid color(default)
or vtkCompositeIndex
Neither of which causes the solution to be displayed.

In the previous version of paraview, i think there used to be a field called volPointInterpolate, which now seems to be missing.
Any clues as to what is wrong?


louisgag July 17, 2008 13:29

change solid color in the top
change solid color in the top bar... not in the display tab.

louisgag July 17, 2008 13:50

I also have the crashing issue
I also have the crashing issues with the new paraview, my computer totally freezes at times and I have to perform a forced reboot.

srinath July 17, 2008 22:13

Hi Louis You were right. I
Hi Louis

You were right. I am posting below the complete list of things that i did, in case someone else gets stuck here.

I did the following and now i am able to display all scalar quantities in paraview-3.3
In object inspector/properties
1)Click on region status to ensure all parts of the internal/boundary mesh are selected.
2)Click on the flow variable(p,U,T etc) that you want displayed
3)Click on apply

In object inspector/display
1)Choose under style/representation--surface

In the top left hand bar(as you correctly mentioned), choose p for eg, if u hv selected p in step 2

In the top right hand corner choose the time instant.

The new paraview does seem better.
Hopefully streamlines etc will be easy to generate.


olesen July 18, 2008 02:38

Louis, I had a similar proble
I had a similar problem a while ago with paraview and icewm. It would exit and then overload my cpu. It turned out to be a nasty bug in how icewm dealt with Qt4 - upgrading icewm did the trick. Maybe you have something similar.

The cell values (eg, U) are displayed as solid dots and the point values are displayed as small dots in the top bar.
As Louis suggested, changing it in the top bar (you might need to select solid color to have paraview notice that there a new fields). Changing in the display tab doesn't seem to work.

You might scan the paraview mantis bug list and see if this bug has been reported and/or fixed in a newer cvs version.

sradl July 19, 2008 11:59

Have the similar problem on as
Have the similar problem on as Louis: when working with paraview 3.3.0 for some while, it freezes, black screen and then i have to reboot.

Qt4 has been installed and the application recompiled - however nothing changed. I'm using linuxMint

I'd kindly ask Mark to give some details on how to manage the problem.

olesen July 21, 2008 02:36

Stefan, Sorry I'm not an ex

Sorry I'm not an expert for any of those things. I just happened to have had a paraview3/qt4/icewm problem in the past. I cursed a buggy paraview3, but tried a variety of other window managers before thinking about filing a bug report. Using this approach I narrowed the problem down to a particular version of icewm. Otherwise, the next step would been to run valgrind on paraview and see if anything interesting shows up. You can also try it with other linux versions to see if you can isolate the problem.

Also try paraview with some simple format (eg, stl) that doesn't use the OpenFOAM reader. If you have the same problem, it is a paraview problem with your installation and not OpenFOAM.

BTW: the problem I had encountered was with paraview3 itself, which I had compiled and installed independently of OpenFOAM. Now that I have OpenFOAM-1.5 installed, I use the bin/buildParaView3.3-cvs script which makes compiling paraview much, much, much more comfortable!

podallaire July 22, 2008 16:38

Guys, be sure that you have

be sure that you have, and in OpenFOAM-1.5/lib/linuxXXXX/ otherwise it won't work.

Paraview load the PV3FoamReader librairies from this directory.



sradl July 25, 2008 02:27

Hi foamers, after precise t
Hi foamers,

after precise testing, the following status:

The only function of Paraview 3.3 that does not work is clip. When I perform a clip and want to show the surface, the monitor is getting dark. All other functions work.

So I think it is a bug in Paraview or an incompatibility with my graphic card or OS (I run on linux mint).

Stefan Radl

richard July 31, 2008 23:12

Hi all, I upgraded to Ubunt
Hi all,

I upgraded to Ubuntu 8.04, and so I had to recompile paraview and pv3foamreader - I've got Qt4.3.4 and had to download libmpfr to get it to work, that's fine.

The problem is when I open a case in paraview and select the region status (all) then hit apply, nothing happens.
The display tab is still blank (just has visibility greyed out) and the window is remains black. There isn't any error file or output.

Am I missing something? Another package maybe?

Any help would be really appreciated - it's bugging the hell out of me.


nishant_hull August 14, 2008 10:48

I am trying to install openfoa
I am trying to install openfoam-1.5 and I can successfully run the case with bloclkmesh and solver commands (like icoFoam etc)
But paraFoam command is not working well.
I have qt-4.3.5 installed by default in my FEDORA-9. I checked the GMP and MPFR installation as well.

The strange thing is .. even thought I installed the qt-4.3.5, the command :
qmake --version
is not displaying any result. what does this mean? Is this has to do anything with the error I am getting below?
The error reported is:-

[343880@w191-210 channel395]$ paraFoam
paraview: error while loading shared libraries: cannot open shared object file: No such file or directory

can anybody help?


aunola August 15, 2008 07:04

Nishant, One possible expla

One possible explanantion is that qmake is not in your path. Say, for a bash shell your .bash file should have something like this in it:


I believe this is where qt4 is on Fedora 9. I'm not sure though that is your problem. If your path is simply wrong the command 'qmake -v' should return 'Unknown command'. Also, you probably wouldn't have been able to rebuild paraFoam and reader if the path was wrong.

Did you do these rebuilds ?

All times are GMT -4. The time now is 16:14.