CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Too many time folders crash foamToVTK (

johndeas September 22, 2008 05:21

Hi, I am using foamToVTK on

I am using foamToVTK on my Ubuntu machine (I need to export the VTK folder to postprocess on another machine).

On version 1.5, if I have too many time folders in my case (around 50 it seems) I get this error notification:

--> FOAM Serious Error :

Too many errors#0 Foam::error::printStack(Foam: in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpe"
#1 Foam::error::abort() in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpe"
#2 Foam: Foam::operator<<>(Foam:, Foam::errorManip<foam::error>) in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/applications/bin/linux64Gc cDPOpt/foamToVTK"
#3 Foam::messageStream::operator Foam: in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpe"
#4 Foam::messageStream::operator()(char const*, char const*, int, Foam::string const&, int, int) in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpe"
#5 Foam::messageStream::operator()(char const*, char const*, int, Foam::IOstream const&) in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpe"
#6 Foam::IOobject::readHeader(Foam::Istream&) in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpe"
#7 Foam::IOobject::headerOk() in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpe"
#8 Foam::IOobjectList::IOobjectList(Foam::objectRegis try const&, Foam::fileName const&, Foam::fileName const&) in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpe"
#9 main in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/applications/bin/linux64Gc cDPOpt/foamToVTK"
#10 __libc_start_main in "/lib64/"
#11 Foam::regIOobject::readIfModified() in "/home/flurec/commun/OpenFOAM/1.5-x86_64/OpenFOAM-1.5/applications/bin/linux64Gc cDPOpt/foamToVTK"

From function messageStream::operator OSstream&()
in file lnInclude/messageStream.C at line 203.

FOAM aborting


Can anyone help ? Thank you ?

niklas September 22, 2008 07:36

only 50? thats nothing. dis
only 50? thats nothing.

disk full perhaps?

1 create a bck directory,
2 move the last timestep to the bck-dir.
3 run foamToVTK
4 if it fails go to 2
5 it works - you've found the directory causing the problem.

or move all timesteps to the bck directory and then move them back 1 by 1 until it fails.

It could be that you've lost the connection for a while to the disk while writing the data (if you're working agains an nfs disk or similar)

johndeas September 22, 2008 12:06

I have found a workaround: I l
I have found a workaround: I launch

foamToVTK -time xxx

using a script, for all my timesteps. It works, so the problem really is the number of time directories, and not a specific one. I have the same problem with both redhat and ubuntu.

mattijs September 23, 2008 15:04

Hi John, Very strange. Do y
Hi John,

Very strange. Do you have sample case that goes wrong? Or can you just do an 'ls' so we can see what time directories you have.

johndeas September 25, 2008 15:07

I tried at home outputing 75 t
I tried at home outputing 75 time directories and importing them without problem to paraview. I though it was related to my linux distro but it is not then. I will try to isolate more the problem then report here.

All times are GMT -4. The time now is 16:48.