CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Parafoam problem (

mochzeen March 4, 2008 08:34

Hi, I'm in the install/testru
I'm in the install/testrun phase of openfoam 1.4.1. Installing all binaries of openfoam and using paraview 3.2.1 (latest) which was installed systemwide. Everything else is running fine (java, gcc installed systemwide as opposed to under a subdirectory within /home/openfoam). The problem is when running parafoam, i got this error message;

Got unknown argument: paraFoam.pvs

paraFoam.pvs is there, so is the parafoam.pvs that came with openfoam1.4.1 not compatible with paraview 3.2.1 since the paraview that comes with openfoam is paraview 2.4.4?

Anyway to solve this? Thanks

jens_klostermann March 4, 2008 08:51

Hi The paraFoam works to my

The paraFoam works to my knowledge only with the paraview 2.x.x not with the paraview 3.x.x.

Just download the paraview which comes with OpenFoam.

There is possibility to use paraview > 3.2.2 (or so) with a native reader, check the forum Native ParaView Reader


mochzeen March 4, 2008 20:31

Thanks Jens! Ooooo... more rea
Thanks Jens! Ooooo... more reading and sleepless nights for me...

chegdan March 17, 2008 12:49

ParaFoam crashes in my install
ParaFoam crashes in my install of Ubuntu 7.10. and kills my session and restarts to the user login screen. Has anyone had this problem recently and how did you resolve it? My installation worked about 2 months ago before I switched to that I'm back on OF, using paraview/parafoam and it seems to hate me. Thoughts?

jussi April 8, 2008 14:22

Hi I am novice running OF o

I am novice running OF on Ubuntu 7.10. I managed to get the installation system check and installation test passed with only following two unset env variables. $LAM_ARCH_PATH is mentioned critical. (see below)

I did manage to run first example with icoFoam cavity and could use FoamX. There the double click was not functional instead right mouse click seemed to do the job.

I was not able to start paraFoam but found following error message.

What should i do

juhani@ubuntujuhani:~/OpenFOAM/OpenFOAM-1.4.1/bin$ paraFoam $FOAM_RUN/tutorials/icoFoam cavity
/home/juhani/OpenFOAM/linux64/paraview-2.4.4/lib/paraview-2.4/paraview-real: error while loading shared libraries: cannot open shared object file: No such file or directory

$LAM_ARCH_PATH --------- env variable not set --------- yes
$MPICH_ARCH_PATH --------- env variable not set --------- no

Checking the FOAM env variables set on the LD_LIBRARY_PATH...
Environment_variable Set_to_file_or_directory Valid Path Crit
$FOAM_LIBBIN ...M/OpenFOAM-1.4.1/lib/linux64GccDPOpt yes yes yes
$FOAM_USER_LIBBIN ...OAM/juhani-1.4.1/lib/linux64GccDPOpt yes yes no
$LAM_ARCH_PATH --------- env variable not set --------- yes

andersking April 9, 2008 03:32

@Daniel, I've had this pro

I've had this problem and filed a bug report for ubuntu

It may be fixed in the next release of ubuntu (due shortly). It might be worth leaving a comment if your graphics card is not the same as mine (mine's an intel X3100).


chegdan April 9, 2008 13:11

Andrew, what a coincidence.

what a coincidence... mine is also an intel X3100 GMA965. However, paraFoam will work slightly (crash only on more intensive and complicated geometries) if you run it in safe mode, disable all of the fancy effects, and talk really nice to your computer. I found that useful as a short term fix. I hope it will be fixed in the next release of Ubuntu!


markc September 22, 2008 02:59

Andrew, Daniel, I have simi
Andrew, Daniel,

I have similar problems: starting paraview causes Linux / KDE to logout. It happens with paraview 3.2.1 but also with version 2.4.4. Videocard is MGA G550 AGP. However some time ago I had the same on a labtop with a different card (Intel if I am right). There I resolved the issue by installing paraview-3.2.1. However now this shows not to work. I probably have to update some package but I have no idea which one.
Any ideas here?



chegdan September 22, 2008 11:16

Mark, I wish I could help.

I wish I could help. I ended up either updating Ubuntu 7.10 to 8.04 or reinstalling Ubuntu out of frustration. I imagine that this isn't an option for you and its a bit overkill. I am running Paraview 3.3 pretty well right now without any problems.

I do remember that I logged into safe mode to make things usable. Also disabling desktop effects seemed to be a big part of the problem as well as removing all of the fancy desktop effects completely. After those changes, I believe it worked.


ngj September 22, 2008 12:33

Hi Mark Try to add the foll
Hi Mark

Try to add the following to


in the section "serverLayout"

Option "AIGLX" "false"

I did help on some graphical problems. What it does, is that it turn off all special effects as mentioned by Daniel.

/ Niels

markc September 22, 2008 15:36

Hi Niels, Dan, Thanks for y
Hi Niels, Dan,

Thanks for yuor help. I tried already the Option AIGLX false. It looked like it worked: paraview continued to start without logging off. However then I was not able to do anything. The buttons did not react on any click. isn't very helpfull here as well.
Search continues,


ngj September 22, 2008 16:49

Sorry to hear that it didn't h
Sorry to hear that it didn't help. I had similar problems with complete crash of X11 on Fedora 9, and installed Ubuntu 8.04.1.
Here the AIGLX solved the problems.

/ Niels

lin September 22, 2008 17:46

Hi,I use Fedora9,have ever had
Hi,I use Fedora9,have ever had similiar but not the same problem when I use "visit". If I click on any menus,then X was killed and I was kicked out immediately.

The time to find the reason is really long,finally I find that ,If I delete the line with "backingstore" in xorg.conf,then everything is ok. This staff was added by myself for some reason.

So my advice is that,if you have ever changed the xorg.conf file,just restore it to the original file and check whether it works.Losing some functionality is better than get X killed.

All times are GMT -4. The time now is 17:02.