CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   ParaFoam problem with cavity case (

roger July 19, 2008 10:25

Hi! I started the "cavity"

I started the "cavity" case (chapter 2: tutorials, page U-26) the other day, I have no problem running the case in FoamX, but I can't view the mesh created in paraFoam. There's a message that says:

"roger@portatil:~$ paraFoam $FOAM_RUN/tutorials/icoFoam cavity
/home/roger/OpenFOAM/linux/paraview-2.4.4/lib/paraview-2.4/paraview-real: error while loading shared libraries: cannot open shared object file: No such file or directory

Does anyone know what "" is? Thanks in advance. Maybe this is a silly question but it's my first time with OF. Bye!!

mgz1985 July 19, 2008 10:40

hi mayol can u please tell
hi mayol

can u please tell me how to view the mesh in paraFoam....I m not using FoamX.....i use a macintosh

roger July 19, 2008 10:53

The tutorial says: "The paraf
The tutorial says: "The parafoam post-processing is started by typing at a command prompt"
paraFoam <root> <case>
"i.e. making the appropiate substitutions for <root> path and <case>, paraFoam is executed on cavity by typing"
paraFoam $FOAM_RUN/tutorials/icoFoam cavity
Then it says: "This launches the Paraview window as shown in picture ... In the selection window, the user can see that Paraview has opened cavity.foam, the module for the cavity case.


mgz1985 July 19, 2008 11:06

thanx....shall try it......
thanx....shall try it......

mgz1985 July 19, 2008 11:55

i tried what u said but i get
i tried what u said but i get the following error..

mayank-guptas-macbook:icoFoam mayankgupta$ paraFoam ~/openfoam/mayank-1.4.1/run/icoFoam cavity
/Users/mayankgupta/OpenFOAM/OpenFOAM-1.4.1/bin/paraFoam: line 75: paraview: command not found

roger July 21, 2008 10:45

Thanks for your help! Is ther
Thanks for your help! Is there anyone who has followed Chapter 2 of the OF's "User Guide"? What do you do when you want to view the cavity's mesh(part 2.1.2)? Do you have problems with parafoam? Any information would be great, thanks!

mgz1985 July 21, 2008 12:02

i was having problems with par
i was having problems with parafoam but then i was asked to try

foamToVTK <root> <case>

after this conversion u can open the file in paraview and visualize worked for me hope it works for u

roger July 22, 2008 05:17

I tried and i have the same me
I tried and i have the same message than before:

"roger@portatil:~$ paraview
/home/roger/OpenFOAM/linux/paraview-2.4.4/lib/paraview-2.4/paraview-real: error while loading shared libraries: cannot open shared object file: No such file or directory"

There's no problem in doing "foamToVTK" but then i can't open paraview (neither paraFoam). I think the problem is produced when "loading shared libraries", but don't know what to do. Thank you guys!

roger July 25, 2008 05:20

The problem is in the "shared
The problem is in the "shared libraries". Anyone know what does it mean? I can not open paraFoam "thanks" to the "shared libraries" I think. Thank you!!!

musahossein September 16, 2008 22:00 is a system library is a system library that you will have to install from your boot disk or down load from the internet. Check your boot disk first (if you have one). Not all linux builds will have it.

I dont know what linux distribution you are running - but if you can, you will save a lot of time and effort if you upgrade to SuSE 11.0

I am running OpenFoam 1.5 on SuSE 11.0 w/o any problems (thus far!)

Regarding not being able to load ParaView, I found that I can load ParaView when I call paraFOAM as follows (and NOT paraView as the documentation states), i.e in the cavity directory:

musa@linux-ip9p:~/OpenFOAM/musa-1.5/run/tutorials/icoFoam/cavity> paraFoam

In other words, you should be able to open it in the case folder (i.e, cavity).

Hope this helps

All times are GMT -4. The time now is 03:44.