CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Dead Keyboard in paraFoam (

pavodive June 23, 2005 06:56

I installed openFoam 1.1 (Para
I installed openFoam 1.1 (Paraview 1.8.5) in my Fedora 3 box, it's running OK, except that the keyboard is completely dead in paraFOAM... It doesn't accept numbers (or any other character, or even delete, bakckspace keys, for that matter), nor keyboard shortcuts.

The mouse works OK, I can select, de-select and move the dials (where they exist), but I can't change the numbers/text in the boxes. (typing won't generate any message in the terminal I used to launch paraFoam).

I searched kitware's discussion forum, and although I found (and read) a lot of treads about keyboard events, I think they're related to another problem (well, I have to admit that I felt like reading chinese, there!)

Any suggestion as to what to do (or what other information I should post here) will be highly appreciated!


chris June 23, 2005 11:06

I just discovered the same pro
I just discovered the same problem this morning after installing SuSE 9.3 this week. The solution is as follows (after much messing around, installing various versions of paraview etc. etc. etc.):

There is some program called scim (Smart Common Input Method) on your system that is now launched at startup. You need to kill it. I did:
- login as root
- ps -e | grep scim
- kill every job involving scim

After that you can enter characters in textboxes in paraview.

PS I discovered this annoying package when I accidentally typed CTRL-SPACE while in emacs. I think the idea is that it allows you to change fonts or keyboards layouts or something.

alberto June 23, 2005 11:27

The problem on SuSE 9.3 seems
The problem on SuSE 9.3 seems strange. I'm using it with both an Italian (it_IT) and an English (en_EN) locale, but paraView always accepts input.

I checked for the scim process, but it doesn't seem to be loaded by default.

Best regards,

chris June 23, 2005 11:36

OK, but if Giovanni can confir
OK, but if Giovanni can confirm that he had scim running then the certainty that scim is the problem goes up from 99% to 100%.

I don't know why scim was there in the first place.

pavodive June 24, 2005 04:47

Thank you guys for the respons
Thank you guys for the responses.
Fedora doesn't have scim, but I killed all the gnome-input-switcher-like processes that I found, experimented with several keyboard layouts, languages, modes, and a lot of other tricks I found when googling for "unresponsive keyboard". I even downloaded ParaView 2.0.3, but nothing seems to help.

I posted to the paraview's mailing list, to see if somebody there can give a hand. If any other person has had this sort of problem, then I'll appreciate your help.



chris June 24, 2005 05:23

If it helps, here are all the
If it helps, here are all the things I found when trying to sort this problem out.
1) I recompiled 1.8.5 - didn't sort the problem
2) I compiled 2.0.3 - didn't sort the problem
3) The versions of the shared libraries that paraview uses were the same between SuSE 9.1 and 9.3 but the problem is only in SuSE 9.3.
4) The annoying scim package popped up when I was running emacs. I killed it. I immediately entered text in text boxes in paraview. I have had no problems since then.

Because of (3), the problem seems to lie 'outside' of paraview. I am therefore not confident that KitWare will be able to fix the problem.

Might be worth comparing what system packages are running in the current version of your OS with an older version to narrow down what, if anything, might be causing the problem.

Good luck - if you solve the problem for Fedora 3, please post the solution on this site.

pavodive June 26, 2005 21:51

Ok, finally solved the problem
Ok, finally solved the problem!! :D

Chris, you were totally right, it has to do with the imput method swithcer! Although I had killed all processes _obviously_ related to language input, I overlooked htt_xbe (, an implemenation of the IIIM.

As soon as I killed the process I could start typing into paraView. Not only that, the start up is now as fast as light!! (It used to almost freeze in the splash screen, when opening paraView).

Thanks for your hint, It really helped!

For people in Fedora or Debian, look for htt_xbe . For those of you in SuSE, look for scim , those are causing you the problem!!

asteria January 9, 2008 05:28

I had same problem until now a
I had same problem until now and tried to compile lots of versions of paraview and it have taken lots of time but it didn't work.
I should have searched this message board earlier.
Like Giovanni and chris, I killed all processes related to scim and now paraview accept my keyboard input.
I use openSuSE10.2 and OpenFOAM 1.4.1 and paraview 2.4.4.
Thank you guys. Good luck to your work!!!


sshyu March 18, 2008 10:56

I found the following process
I found the following process cause the problem:
/usr/lib/scim-1.0/scim-launcher -d -c socket -e socket -f x11

After I kill it, paraFoam works well.
But, it is quite bothersome. This process starts every time I login. So, I have to kill it everytime before I use paraFoam. Is there any way around?

sshyu March 18, 2008 22:34

OK! Here is how I did: vi .s
OK! Here is how I did:
vi .scim/config
change /FrontEnd/X11/Dynamic = false to /FrontEnd/X11/Dynamic = true
But I didn't do the "im-switch" stuff. So I am not sure if it would affect other application.

All times are GMT -4. The time now is 19:18.