CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Paraview cannot startup (

gnom April 11, 2007 13:35

On my local PC I am using Xter
On my local PC I am using Xterm (exceed) to connet to the linux server on which the openFOAM is installed. But when I type the conmand "paraview", the paraview windown does not open up, and the error message says "Xlib: Extension "GLX" missing on display "".

Please help. Thanks

mardit June 8, 2007 08:32

You need to update the driver
You need to update the driver of your graphic card - if it is NVIDIA go to the website download latest driver, follow instruction to install and it should work.
I had the same problem.

scottneh October 7, 2009 00:30

I have been experiencing the same problem but I have the lates nvidia drivers and have loaded the glx module in but still get the same error. Any other ideas? Could some libray file be pointing to the wrong location for the OpenGL drivers?


l_r_mcglashan October 8, 2009 05:11

Does 'glxgears' show up an animation?

I have had various problems with paraView on different machines, and I find the best way is just to compile it from scratch. Your problem could be related to a number of things. What steps have you taken?

bigphil October 9, 2009 13:02


A number of guys in my research group have similar errors connecting (using xterm) to our linux server. Yet the guys in the room using Mac don't have this problem. The work around the windows' guys do is:
they install paraview for windows on their windows machine (obviously ;)), and then run foamToVTK and use scp/sftp to transfer the VTK files to their windows machine for post-processing with paraview.
It's a bit annoying but if you use a gui scp/sftp program like winscp ( then it's fine.
Luckily I use Mac and don't have this problem, but this is a handy work-around.

This does not solve your problem but gets around it, as Laurence said the problem could be related to many different things.

Hope it helps,
Philip C

scottneh October 9, 2009 13:43

I'm currently working this issue in Gentoo Linux on another forum and it has to do with the GLX module not being loaded properly due to an nVidia driver mismatch. I suspect that this is an nVidia issue and not a GLX or Paraview issue.

I'll post a complete solution and steps on how to resolve it a a few days once I have it worked out on my end

scottneh October 14, 2009 00:30

ok so here is what I have found. I am using an ASUS board with an nVidia graphics card and running Gentoo linux.

This issue comes from using the "nv" drivers under the Module section in the Xorg.conf file which defines how your desktop is laid out. The "nv" drivers do not have any 3D accelration and will not load the GLX module. To correct this you need to make sure you have the latest nVidia drivers installed and replace "nv" with "nvidia" in your Xorg.conf file. Also you need to add Load "glx" in the Module section. I do not have the latest drivers so I am having to work out a low resolution issuse. Check your version of linux to see what file you have to define the desktop layout and make sure you have the closed source nVidia drivers. Everything should work after that.

All times are GMT -4. The time now is 15:05.