CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   No foam file (

jhierroa December 14, 2005 18:12

I have recently installed Open
I have recently installed OpenFoam-1.2 and paraview-2.4 in an AMD64 with linux and everything seems to work, yet I do not get any .foam file.

I have run the cavity tutorial and got 0, 0.1, ..., 0.5 subdirectories with U and p data but no cavity.foam anywhere.

When I try to run

paraFoam <root> cavity

it complains with

# Error or warning: There was a VTK Error in file: /home/hierro/paraview-2.4.1/GUI/Client/vtkPVWindow.cxx (2364)
vtkPVWindow (0x460daa0): Cannot read file information when no reader is specified. This probably means that the reader for the file with name: /home/hierro/OpenFOAM/hierro-1.2/run/tutorials/icoFoam/cavity/cavity.foam cannotbe found
ErrorMessage end
# Error or warning: There was a VTK Error in file: /home/hierro/paraview-2.4.1/GUI/Widgets/vtkKWApplication.cxx (1335)
vtkPVApplication (0x43d0e10):
Returned Error on line 11:
invalid command name ""
ErrorMessage end

If I create a dummy cavity.foam, it happens the same and the dummy file is deleted.

mattijs December 16, 2005 05:49

paraFoam (i.e. the Foam reader
paraFoam (i.e. the Foam reader module) unfortunately is only compatible with the version of paraview we ship.

Any new version of paraview seems to have a slightly different api for reader modules and we have to modify paraFoam/vtkFoam to make it work.

Use foamToVTK instead or use the old paraview version.

hjasak December 16, 2005 07:03

Incidentally, I am running par
Incidentally, I am running paraview version 2.4.1 and there's no problem. Do you by any chance have an extra trailing "/" in the name, e.g.

paraFoam $FOAM_RUN cavity/ (this is wrong!)
paraFoam $FOAM_RUN cavity (this works)



jhierroa December 17, 2005 19:10

Well, in the end, I think I ha
Well, in the end, I think I have been able to solve the problem by checking the compilation logs (./Allwmake 2>&1 | tee Allwmake.log).

First, it looks like OpenFoam looks for Java3D in some point (it is not said in the documentation).

Last but not least, there is a FoamReader module which looks for the VTK headers. Paraview-2.4.1 is built in a directory different from the one with the source code and the installation does not copy the headers.

I checked bashrc inside .OpenFoam/apps/paraview and made sure of OpenFoam being able of finding all the .h VTK files by copying them in an include subdirectory of the installation directory (the one of paraview). I also had to create a symbolic link (from lib/paraview in the installation directory) into one .cmake file because the OpenFoam compiling process complained that it could not find it.

Now, paraFoam seems to work but for some details (for instance, the stream module causes an error).

mattijs December 19, 2005 14:31

Thanks for the info. > Java
Thanks for the info.

> Java3D.
the experimental PatchTool uses Java3D. If you can live without it you don't need java3d

By the way, does anyone know a better tool/way to apply patch information? Are there any tools out there that can e.g. change surface regions given say an STL file?

> Paraview headers
Known problem. cmake does not copy them unfortunately.

senocak February 9, 2006 16:52

I have the same problem and co
I have the same problem and couldn't resolve it although I followed Juan's suggestions.
Here is my situation.

I build OpenFoam from source on an Athlon cluster. I am able to run FoamX.

I downloaded paraview-2.4.2 and I am able to run it too.

I copied the vtk header files to:

I installed cmake:

When I launch parafoam
"paraFoam $FOAM_RUN/tutorials/icoFoam cavity"
it complains that cavity.foam not found (paraview launches but do not show the cavity mesh)

Apparently, I am missing the ""

I made a symbolic link to cmake in the following directory


ln -s /home/senocak/temp/cmake-2.2.3/bin/cmake .cmake

Then I do "Allwmake" in the following directory


and get the following error.

"CMake Error: ParaView_DIR is not set. It must be set to the directory containing ParaViewConfig.cmake in order to use ParaView.
ParaView is required. Set ParaView_DIR."

I have already changed the cshrc file to point to the correct paraview version (2.4.2)

i tried creating a symbolic link from /lib/paraview to .cmake but it didn't help because Allwmake complains that it cannot find cmake.

Any idea on how to get paraFoam working? Am I missing some of the steps.


mattijs February 10, 2006 06:05

Paraview_DIR and ParaView_INST
Paraview_DIR and ParaView_INST_DIR are set in the .OpenFOAM-1.2/apps/parabiew/bashrc script.

They are needed by the PVFoamReader build to find the include files in the Paraview directory.

It probably requires a bit of puzzling to get everything to compile. Paraview installations tend not to include all the include files needed. Also the Paraview installation directory structure tends to change from version to version.

senocak February 10, 2006 17:17

I managed to build the PVFoamR
I managed to build the PVFoamReader. I now have the under /OpenFOAM/OpenFOAM-1.2/lib/linuxGcc4Opt.
I had to install first paraview 2.4.2 and change paraview installation directory related information in .OpenFOAM-1.2/apps/paraview/cshrc

"include" directory under paraview was not created so I copied the include directory from the paraview 2.2. I am not sure if this step is necessary or not. I have cmake installed also.

Anyways, when I start paraview, it prints the OpenFOAM logo on the terminal screen, and foam case files are recognized under "open data" menu too. FoamX runs fine. I ran the cavity case but when I type

paraFoam $FOAM_RUN/tutorials/icoFoam cavity

paraview crashes with segmentation fault.

/home/senocak/OpenFOAM/OpenFOAM-1.2/bin/paraFoam: line 57: 27873 Segmentation fault paraview paraFoam.pvs

Any idea on what causes this segmentation fault?

For now,I convert data to VTK format and view it with paraview.

hjasak February 10, 2006 17:22

Yup, happened to me on a Mac:
Yup, happened to me on a Mac: try compiling paraview with Debug options. If this works (it should), drop the optimization in paraview cmake setup to -O1 (in advanced options) and the problem will go away.


hjasak April 12, 2006 06:24

An ansrew to the original ques
An ansrew to the original question in the stream: no .foam file: if you have a trailing / in the name of the case, paraFoam complains about the missing .foam. Thus:

wooster*108-> paraFoam . naca0012/
touch: cannot touch `naca0012/.foam': No such file or directory


paraFoam . naca0012

works. So, don't put trailing / into the command line.


jhierroa October 4, 2006 06:48

Well, the file that I had to e
Well, the file that I had to either copy or link


into the directory $ParaView_DIR

All times are GMT -4. The time now is 17:40.