CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Has anyone had luck with paraFoam on RedHat Enterprise AMD64 platform (

sek August 24, 2006 09:13

OpenFOAM and FoamX run fine. B
OpenFOAM and FoamX run fine. But paraFoam crashes. Can someone please suggest a workaround?

gschaider August 24, 2006 11:21

I have paraFoam here running o
I have paraFoam here running on CentOS 4.3 (which is essentially RHEL) without problems. In my experience it's more difficult to get FoamX to run without problems.

Could you supply us with a more detailed description of the crash?

(One of the main reasons for crashing paraFoams - in my experience - are old paraview installations. But that's really the best guess I can give you)

msrinath80 August 24, 2006 12:17

I have Scientific Linux 4.1 an
I have Scientific Linux 4.1 and works fine here as well.

sek August 24, 2006 16:40

Both paraview and paraFoam dow
Both paraview and paraFoam downloaded with OpenFOAM 1.3 crash immediately without any error messages after showing the paraview logo in a split of second. It even logs me off!

I tried to recompile paraview, but ran into another problem, which appears to be due to the compatibility issue (gcc 4.1.0 and /usr/bin/ld) discussed somewhere in the message board.

gschaider August 24, 2006 17:20

That sounds heavy. With "log o
That sounds heavy. With "log off" you mean that the X-Server crashes?

Some things come to mind (but none of them a solution):
- try the original binary from (make sure with 'which paraview' that you are using the right one). If that crashes too, the OpenFOAM-paraview isn't guilty.
- have you ever used a OpenGL-application on that machine?

I'd think that the problem is somewhere in the X-Server/OpenGL/GraphicCard-Driver-complex

sek August 25, 2006 15:01

That's right. The X-server cra
That's right. The X-server crashes and I need to relogin. The binary downloaded from the paraview website crashes exactly like the one from OpenCFD.

gschaider August 27, 2006 16:52

Then I'm afraid you'll have to
Then I'm afraid you'll have to check with the paraview-mailing list.

Just one idea (but I've never tried it, therefor don't know if it works and I can't check due to a lack of a crashing paraview ;) ): starting paraview with (assuming you're using the bash)

nohup >/tmp/paraviews_last_words 2>&1 paraview &

might(!) give you the last output of paraview that usually goes to the terminal (which might(!) show the reason for crashing).

sek August 28, 2006 14:38

Hello Bernhard It indeed giv
Hello Bernhard
It indeed gives diagnostics that sounds serious.
Thanks for your suggestion.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 4594 requests (4591 known processed) with 0 events remaining.
X connection to :0.0 broken (explicit kill or server shutdown).

sek August 28, 2006 14:51

And glxinfo gives me this.
And glxinfo gives me this.

X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 146 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x2800002
Serial number of failed request: 22
Current serial number in output stream: 22
name of display: :0.0

sek August 29, 2006 12:28

Hello Bernhard, Thanks for
Hello Bernhard,

Thanks for pointing me to the right direction. Your comments help me trouble-shoot the Xterm/OpenGL problem. The grahics card driver turned out to be faulty. Thanks again for your help.

All times are GMT -4. The time now is 07:02.