CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Both paraview and paraFoam crash on Redhat Linux WS v4 64bit (

sek August 17, 2006 09:45

Running either paraview or par
Running either paraview or paraFoam crashes immediately after entering the command line. It seems to launch paraview, showing the paraview logo in a split of second. But it crashes instantly and even logs me off! I'll appreciate if anyone can enlighten me with any clue to what's happening and trouble-shooting.

sek August 17, 2006 09:49

I should've said I'm using Ope
I should've said I'm using OpenFOAM 1.3 along with paraview 2.4.3.

ziad August 17, 2006 12:14

I had a similar problem on ubu
I had a similar problem on ubuntu dapper drake 64bit and several versions of paraview. posted but no replies yet. see

It is a resource problem but since there is enough memory (512Mb) I suspect this might be the compiling options of paraview. doesn't seem to be connected to foam since it runs just fine in 64bit, so probably have to recompile...

sek August 17, 2006 15:15

I tried to rebuild paraview. B
I tried to rebuild paraview. But I got the following error while trying to compile. Has anybody seen this before? I don't quite understand why the linker bothers with /usr/lib/ I thought it should look for /usr/lib64/, as my CMakeCache.txt file says.

[sek@KimS paraview-2.4.4-obj]$ make
-- Found existing Tcl, not rebuilding
-- Found existing Tk, not rebuilding
Linking CXX shared library ../../../bin/
/usr/bin/ld: skipping incompatible /usr/lib/ when searching for -lGL
/usr/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status
make[2]: *** [bin/] Error 1
make[1]: *** [VTK/Utilities/ftgl/CMakeFiles/vtkftgl.dir/all] Error 2
make: *** [all] Error 2
[sek@KimS paraview-2.4.4-obj]$

ziad August 17, 2006 16:26

how about linking /usr/lib/lib
how about linking /usr/lib/ temporarily to /usr/lib64/ just for building paraview. you can reset the links after. might solve your problem.

All times are GMT -4. The time now is 18:48.