CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   ParaFOAM using binaries (

tj22 April 12, 2006 08:49

I successfully built OpenFOAM
I successfully built OpenFOAM and the pvreader and after so editting of the parafoam script it worked fine.

I am now trying to get the same results from the binaries. so I downloaded OpenFOAM-1.3 and General. I extracted them both to /$HOME/OpenFOAM/OpenFOAM-1.3. I sourced the bashrc and did an allrun a tutorial worked fine. so I downloaded your paraview-2.4.2.linux and extracted it to /$HOME/OpenFOAM/linux/paraview-2.4.2.

I am getting the following error when trying to run paraFoam:
paraFoam /$HOME/OpenFOAM/OpenFOAM-1.3/tutorials/turbFoam cavity
# Error or warning: There was a VTK Error in file: ../../../../../paraview-2.4.2/GUI/Client/vtkPVWindow.cxx (2364)
vtkPVWindow (0x825aba8): Cannot read file information when no reader is specified. This probably means that the reader for the file with name: /$HOME/OpenFOAM/OpenFOAM-1.3/tutorials/turbFoam/cavity.foam cannot be found
ErrorMessage end

Any ideas?


tj22 April 12, 2006 11:12

Nevermind I had to make some c
Nevermind I had to make some changes to the paraFoam script but it now works.

ghazi July 10, 2006 05:59

hi Tarry , what did you do????
hi Tarry , what did you do?????

tj22 July 11, 2006 12:19

In the OpenFOAM/bin dir there
In the OpenFOAM/bin dir there is a paraFoam file make sure the path to the .pvs file is correct.

Also you will need to make changes to the paraFoam.pvs to point it to the tutorial files you are trying to open.

All times are GMT -4. The time now is 20:43.