CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Some problem with paraview (

thermo November 22, 2005 05:24

I've just installed OpenFOAM,
I've just installed OpenFOAM, which can calculate normally. But there seem some problems with paraview. At first,when I execute paraview, it simply tells that '.../paraview: cannot execute binary file'. So I download another paraview(version-2.2.1) instead. This time,the paraview can work! But a new problem arises,when execute:
paraFoam ... ...
it refers:

# Error or warning: ERROR: In /home/amy/ParaViewReleaseRoot/paraview-2.2.1/Utilities/VTKClientServer/vtkClient ServerInterpreter.cxx, line 866
vtkClientServerInterpreter (0x805cf40): Cannot find module "". The following paths were searched:

ERROR: In /home/amy/ParaViewReleaseRoot/paraview-2.2.1/GUI/Client/ x, line 677
vtkPVXMLPackageParser (0x8636630): Error loading Library component PVFoamReader

ErrorMessage end

There isn't the dir '/home/amy...' at all. And there is no 'PVFoamReader' too.
who can help me to solve it, thanks a lot.

wikstrom November 22, 2005 08:41

Hi, here it is, I would thi

here it is, I would think (from above):


You have to set $ParaView_VERSION in


Assuming that you keep your new paraview-2.2.1 in $WM_PROJECT_INST_DIR/$WM_ARCH/

thermo November 22, 2005 10:28

I tried as suggested,but it ha
I tried as suggested,but it has no effect. The situation looks like the same as I posted at first.
hmmm,it mainly mentions:

ERROR: In /home/amy/ParaViewReleaseRoot/paraview-2.2.1/GUI/Client/ x, line 677
vtkPVXMLPackageParser (0x864ddb0): Error loading Library component PVFoamReader
/home/wzx/OpenFOAM/OpenFOAM-1.2/bin/paraFoam: line 57: 3608 section wrong paraview paraFoam.pvs

The dir, '/home/amy/....', seems strange. I cannot find it at all.
Execute 'paraFoam paraFoam.pvs' directly, paraview starts,but ends at once, hehe.

hemph November 22, 2005 10:40

The /home/amy-part comes from
The /home/amy-part comes from the directory where the PVFoamReader was built originally, it is ok. You must use the paraview supplied with OpenFoam to be able to use paraFoam. Here it looks like you are using the version you downloaded from paraview homepage instead. If you wish, you can run foamToVTK on your case and use paraview to look at the results.

Did you download the correct paraview for your architecture from OpenFOAM download page?

thermo November 22, 2005 10:46

en,i did download the paraview
en,i did download the paraview supplied with OpenFoam...but it didn't work at all.
it happens that another person meet the same problem, look down.

hemph November 22, 2005 10:54

I downloaded paraview for linu
I downloaded paraview for linux a couple of days ago without any problems (for OpenFOAM-1.2). (I believe the problem of below is different, paraview was not found which indicate some error in the installation process.)
My is in
if yours is not there, you should try a reinstall of the OpenFOAM binary pack for linux.

unoder November 25, 2005 14:44

Strange, suddenly I also got m
Strange, suddenly I also got myself a problem with paraview/parafoam. I has worked for 2 months and when I start it now it says:

/home/martin/OpenFOAM/OpenFOAM-1.2/bin/paraFoam: line 57: 8710 Segmentation fault paraview paraFoam.pvs

This is really strange. I restarted and still got this problem with all my cases. Perhaps reinstallation is the only way out now...

mattijs November 25, 2005 17:37

1. Maybe there is something in
1. Maybe there is something in your ~/.Paraview* files it is not happy about?

2. Unsetenv PV_INTERFACE_PATH and try running paraview instead of paraFoam.

unoder November 26, 2005 18:09

Hey, thanks a lot Mattijs,
Hey, thanks a lot Mattijs,

I just did a:

martin@linux:~> rm .ParaViewlmk
martin@linux:~> rm .ParaViewrc

And now everything seems to work again. I have absolutely no idea what might have screwed those files up, but the important thing is that now it works again and it was easy to fix :-)

liugx212 December 20, 2005 20:32

Dear Martin Jørgensen: I ha
Dear Martin Jørgensen:

I have the same question as you. But I really do not know what you said "martin@linux:~> rm .ParaViewlmk
martin@linux:~> rm .ParaViewrc ".

Could you please give more help?

Thank you very much.

unoder December 25, 2005 14:20

Those are hidden files. Theref
Those are hidden files. Therefore you wont see them unless you write "ls -a". As I remember it, they were placed in your home directory. So you should be able to type:

1) cd ~ (or I think just "cd" would do the same)
2) rm .ParaViewlmk
3) rm .ParaViewrc

And then everything worked, at least for me.

All times are GMT -4. The time now is 11:15.