CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   ParaView-3.7.0(cvs) + OpenFOAM Reader issues (

philippose June 5, 2009 14:31

ParaView-3.7.0(cvs) + OpenFOAM Reader issues
Hello there,

A Good Evening and TGIF :-)!

Couple of days ago I compiled the latest CVS version of Paraview (3.7.0-cvs) on two machines.... one was my laptop at home [Centrino 1.6GHz - 32bit; 512 MB RAM; Fedora 10 (32bit)], and the other... one of the machines at work [Intel Core 2 Duo 2.4GHz - 64bit; 3 GB RAM; Fedora 10 (64bit)].

After compiling and installing ParaView into the "ThirdParty" folder, I recompiled vtkPV3Foam and PV3FoamReader so that they would be compatible with the new version of ParaView.

On the Laptop, the OpenFOAM reader (through paraFoam) is working perfectly fine, but on the machine at work when I run paraFoam, ParaView-3.7.0 starts up, loads the OpenFOAM case, but then, nothing but a very thin line of sparsely located points appear on the screen.

No error windows pop up, neither ParaView nor the OpenFOAM reader complains about anything unusual.... all the patches, fields and time steps are listed in the respective locations, and when I change the time-step, ParaView even shows the progress bar stating that it is updating the changes....

Basically, I am not able to figure out what the reason could be..... the only difference I can see between the two systems, is that one is a 32-bit setup whereas the other is a 64-bit setup.

Additionally, I am able to view for example the "cone" source, and also open the OpenFOAM case once I convert it to the VTK format using foamToVTK (on the same ParaView-3.7.0 setup)..... proving that it is not a generic graphics problem...

Any ideas from any of the bleeding edge ParaView users?? Takuya... any leads??

Have a lovely weekend !!


podallaire June 5, 2009 15:42

Hi !

I have compiled 3.7.cvs yesterday on Mac and Linux machines with Takuya's reader / no problem here. However, I did not try pvFoam. I can confirm that the reader works perfectly.



philippose June 5, 2009 17:08

Hello there,

Thanks for that confirmation :-)!

I have not tried Takuya's reader with the latest version of Paraview yet... unfortunately I cannot use the reader for sliding mesh cases (yet).

However, currently this weird problem I am facing is related to the Paraview reader (PV3FoamReader) which is supplied along with OpenFOAM-1.5.

What is bothering me, is that the same code base is running fine on one system (32-bit), while it refuses to run on another (64-bit).... but at the same time, does not throw up any errors or warnings.

Any ideas?


sushant June 6, 2009 07:16

Paraview on Mac
@podallaire: I was trying to compile Paraview (3.4) on Mac OS 10.5.7 with Qt 4.3.5. Everything compiles well but when I run Paraview it always dies with a segmentation fault. Any ideas?


gschaider June 6, 2009 21:00


Originally Posted by sushant (Post 218431)
@podallaire: I was trying to compile Paraview (3.4) on Mac OS 10.5.7 with Qt 4.3.5. Everything compiles well but when I run Paraview it always dies with a segmentation fault. Any ideas?

If you called paraview by itself (no paraFoam) then this is a typical case for the paraview-mailing-list (because it is a "pure" Paraview problem)

podallaire June 7, 2009 09:55

@Philippose: Sorry, I did not try paraFoam / I did not know that a sliding mesh does not work with the reader, is there a tutorial that I can try for this ? ... The only thing that I can say is that 32 / 64 bit worked for me.

@Sushant: it is difficult to troubleshot without knowning what you tried / did you enable the shared lib flag ?

@ Bernhard: so, did you enjoy Montreal ?

7islands June 7, 2009 19:47

Hi Philippose,
Do you know or have a reproducing case of the sliding mesh problem that you can share? I tried two or three of sliding mesh cases floating around but have not had a problem so far.

As to the graphics problem, I read somewhere (the paraview or visit-users lists) that if you are using a ATI graphics you may at times have such subtle problems....


philippose June 9, 2009 06:45

1 Attachment(s)
Hello Takuya,

Good to hear from you again after a long time :-)! Hope eveything is coming along well !!

Regarding postprocessing of sliding mesh cases with your version of the OpenFOAM reader... It currently does not work, because the sliding interface system (as implemented in OF-1.5-dev) generates stand-alone faces.... faces which do not have corresponding "owners"...

This does not seem to be a situation the reader particularly likes to live with, and it aborts with an error as shown in the attached screen shot.

I also noticed that there have been some changes made to the Paraview-3 reader which comes with OpenFOAM to handle such standalone faces.

And now for the other problem I have been fighting with..... well.... this is with regard to the Paraview reader which comes with OpenFOAM-1.5-dev (PV3FOAMReader)...

After a lot of poking and prodding, it looks like the mesh created in the file "vtkPV3FoamUpdate.C" using the completely standard OpenFOAM formulation:

meshPtr_ = new fvMesh ( IOobject(.......) )

for some reason (and again... only within this reader utility), treats the mesh point co-ordinates as text elements, and truncates everything past the decimal point (for example, if a co-ordinate is listed as 5.2e-5 when I use a simple program to list all the mesh co-ordinates again using OpenFOAM functions... it lists it as "5" when printed from within the above file !!!)..

I basically have no idea (yet) why this is happening.... and its really getting on my nerves :-)!

The worst part is, that the exact same code when compiled on my laptop (using 32-bit) gives me a co-ordinate listing as normally expected!

Further... if I scale the mesh using "transformPoints" so that the significant digits of the co-ordinates are to the left of the decimal point, then things start looking better (because even if it truncates past the decimal point, most of the location data is still retained....!)

Could someone please tell me how something like this might happen in C++ !?!?

Have a nice day!


7islands June 9, 2009 09:27

Hi Philippose,
Thanks a lot for the report. I found one of such cases and made a modification to the reader. Can you downlowd the reader from

svn co
, replace vtkOpenFOAMReader.cxx with yours in your ParaView sources, recompile ParaView and see if this works?

@Decimal point problem: I read somewhere (again, perhaps on the paraview-list) that your locale setting may affect how decimal points are interpreted by the system routines (strtod() for instance). So setting for example LANG=C may (or may not) change the behavior?


philippose June 9, 2009 10:49

Hi Takuya,

What can I say :-)! As in.... now thats called hitting the nail on the head :-O !! All I can muster up is..... "respect" :-)!

I can finally sleep in peace tonight, and I can finally get down to my normal day to day work....!!

Changing the LANG environment variable from "de_DE.UTF8" to "C" solved the decimal point issue without any complaints....

The only thought I have now is.... why does the creation of an "fvMesh" in one utility depend on the Locale... whereas the rest of OpenFOAM works without any issues and has always worked without any problems even though the locale was set to German?

As I said... I had quickly put together a small utility similar to "writeCellCentres", which printed out all the co-ordinates without any problems under the same locale conditions....

Hmmm.... one learns something new everyday :-)!!

As for your modified OpenFOAM reader.... shall compile that once I get back home, and shall give you feedback in about 3 to 4 hours....

Once again.... thank you very much Takuya !!

Have a great evening ahead!!


philippose June 11, 2009 05:32

Hello again Takuya,

Sorry for the delay in replying regarding the change in the reader that you made...

I had not recompiled Paraview on my system since version 3.5.0, and compiling 3.7.0 took a long time....

Anyway.... just wanted to confirm that the changes you made work perfectly fine, and I am able to post-process sliding mesh cases using your reader in both Windows and Linux now :-)!

Thanks a lot!

Have a great day ahead !!


7islands June 11, 2009 08:44

Thanks for the report again, and have a nice day!


tino_boelke June 11, 2009 17:49

Yes, it works! ... had the same problems with ParaFoam since i installed Ubuntu 9.04. After clicking apply the model was loaded in but nothing appears on the screen.
Changing the LANG enviroment variable from LANG=de_DE.UTF-8 to LANG=C fixed this problem... really curios :confused:.

But so far, im able to work now, thanks alot for your hint!


deepsterblue June 15, 2009 11:31

Does this version of Paraview have animation export options to AVI/MPEG? I recall 3.4.0 having licensing issues. I really don't want to use ImageMagick/MPlayer, etc.. They're just a huge memory hog.

gtampier February 10, 2010 07:37

Amazing... I'm struggling since many days with paraview & paraFoam problems (same problem as philippoise: 32bit OK, 64 not. Additionally I had a rendering problem when selecting point fields). I was supposing all the time was about m ATI card in the 64 machine. Now I changed the LANG variable to C and ALL problems are gone. Thank you guys!

egp February 15, 2010 05:49

Pulled the latest snapshot of ParaView 3.7.0. Compiled 3.7.0 and Qt 4.6.1 on my Macbook Pro (arch=x86_64). Was nice to see that Takuya's plugin is now included in the ParaView distribution during the build process,

All times are GMT -4. The time now is 12:57.