CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Problem with paraFoam (ubuntu 9.04) (

peb August 3, 2009 09:22

Problem with paraFoam (ubuntu 9.04)
Dear everyone,

I use binary version of OpenFOAM. I have upgraded my ubuntu from 8.10 to 9.04, and since, I have this strange behaviour.

paraFoam seems to not prepare data. I have paraView opening well, with <my problem>.OpenFOAM properties selection, but no data anymore. If a export to VTK, and open with paraView, I can work as usually.

I have tried with OF1.5 and OF1.6, with the same behaviour. Working from blockMesh or gmshToFoam also doesn't change anything.

Do you know how I could work out to find what is my problem ?

(previously it worked on Ubuntu 8.10 and OF1.5, but I cannot come back to that easily).

Thank you for your help !

peb August 3, 2009 12:14

I noticed also that my <problem>.OpenFOAM file created by parafoam is empty. Could be a clue ?

murrayjc August 22, 2009 00:10

I think the <case>.OpenFOAM file is always empty. As I understand it, its just a dummy file created so that you can select a (single) file in the GUI file import utility within ParaView. The PV3FoamReader is then supposed to figure out what to do with the OpenFOAM field files in the case directory.

Regarding your problem with paraFoam not loading your case data, I had a similar issue using the original binary for paraFoam when I first installed OpenFoam (LinuxMint Elyssa 32 bit). My problem was fixed with a recompile of ParaView 3.6.1 and the PV3FoamReader module as directed by the OpenFoam installation README here:

peb August 24, 2009 08:28

Thank you for your answer.

I tried this morning to compile ParaView and PV3FoamReader, but it did not change the behaviour. I've also tried to copy the compiled .so files in the plugin directory (in order for ParaView to use the correct libs), but I still did not succeed in reading my data.

To my understanding, PV3FoamReader is not able to read data. When I open my case, there are wrong values in the "information" tab of the object inspector - comparing to the same case opened through VTK. Number of cells is OK, but p, U and time are not.

For the moment, I still use it through VTK, and still try to find a good solution.

Thank you again.

peb August 24, 2009 09:50

I had a suspicion about decimal point after the post. I tried to scale my mesh (in order to be > 1), and then saw something. I search with that base and found this post :

I did : export LANG=C before paraFoam, and ... it finally works !

I assume there are some function, lost in a lib making reading following my language (even with a KDE config with .) and looking for , instead of . in files.

By the way, having paraView compiled on my system is a good option. Some other weird behaviors of the interface are also gone.

All times are GMT -4. The time now is 08:16.