CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Cell Data to Point Data Issues (

mcintoshjamie November 15, 2009 07:33

Plotting Streamlines - Issues

I'm using Paraview 3.6.1 and attempting to create a velocity vector from fluent results and then plot these as a streamline.

My current understanding:
1) I need to create a velocity vector from point data of the form:
2) I need to produce a glyph of this vector
3) Use the stream tracer filter

1) From the screenshot (1) below I've achieved this but only for "Attribute Data: Cell Data." When I select point data then I have no access to the data I need. (ie the only scalars left are coordinates - I need velocity)

I attempted to use the Cell Data to Point Data filter but as you can see my model disappears and it appears to not have worked correctly. (Screenshot 2)

This is confirmed when I attempt to create a point data calculator for the vectors I need with nothing showing. (Screenshot 3)

2-3) Will be simple when 1 works!

Any help will be appreciated as I'm sure this is just a simple fix and I'm just missing something. Thanks for your time.


mcintoshjamie November 15, 2009 17:28

Right I've managed to create some vectors by using the "Cell Centers" and then "Glyph" filters but it's not the result I'm aiming for (Screenshot 1). I'm trying to produce a streamline which shows the route the particles follow as they move through the model and any assistance with this final step will be really appreciated.

I've tried using the "ParticleTracer" filter and get the following:

p, li { white-space: pre-wrap; } ERROR: In /builddir/build/BUILD/ParaView3/VTK/Filtering/vtkDemandDrivenPipeline.cxx, line 728
vtkCompositeDataPipeline (0x2b7a060): Input port 1 of algorithm vtkTemporalStreamTracer(0x2e67f00) has 0 connections but is not optional.

I've also tried using the "Particle Pathlines" filter which doesn't give an error yet doesn't produce any pathlines. Result shown in Screenshot 2.

I've also tried the "StreamTracer" filter with no joy as shown in Screenshot 3 --> Nothing produced.

Please help, I'm sure I'm just missing something simple.

mcintoshjamie November 19, 2009 04:55


I'm still trying to sort this problem out with no luck. Any suggestions will be appreciated!


All times are GMT -4. The time now is 15:06.