CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Segmentation fault with paraview 3.10.1 (

aot July 22, 2011 09:22

Segmentation fault with paraview 3.10.1
Dear all,
i'm running paraview with OF 2.0 and suddenly got problems. Opening a decomposed case with paraview runs fine but if I try to open something like the color legend or some filters paraview crashes with segmentation fault and without further explanation.

I tried to install paraview again from source but nothing changed.
I'm running kubuntu 10.04, Qt version 4.6.2, and already updated cmake from version 2.8.0 to 2.8.5.

Paraview 3.10.1 ran fine without problems for a long time also with OF 2.0. I think the problems started with a kernel update.

Does somebody have an idea how to solve this problem.

Thank you in advance


wyldckat July 22, 2011 17:35

Greetings Andreas,

I can only think of four possibilities:
  1. Indeed it could be a Kernel problem. If the error message is something like the one on -> this comment <-, then yes it could be a kernel problem. In Synaptic or KPackage, you should be able to revert back to the previous kernel version... Or simply pick the previous one from the grub boot list when your computer starts.
  2. The settings file for ParaView in your home folder might have gotten damaged somehow. This has been known to happen in the past with ParaView 3.8, but I thought that it should be fixed by now. Either way, try erasing the folder "~/.config/ParaView".
  3. It could be a more annoying problem: glibc or Qt might have been updated as well. This might have had an unexpected side effect on ParaView itself or only on the reader used to open the OpenFOAM cases. So, here it really depends on the reader version you are using to open the cases: is the file extension .OpenFOAM or .foam?
    If it's .OpenFOAM, try running paraFoam like this:

    paraFoam -builtin
    This will open with .foam. If the crash still occurs, then it's probably ParaView that got broken with something else.
  4. The OpenGL drivers might have been modified. These are usually tightly connected to the Graphics card drivers. If these got updated and ParaView started crashing, then something bad is going with the drivers, specially if you already tried rebuilding ParaView from source. Going backwards to the previous driver version might fix the problem.
Best regards and good luck!

aot July 25, 2011 13:43

Hi Bruno,
thank you very much for your reply. I also think it was a problem with the OpenGL-drivers. Instead of investing too much time in this I used the possibility to reinstall and update my new system ;) ...


vnarayana November 12, 2015 13:50

Good evening Bruno,
i have been observing that you are helping the people by giving wonderful suggestions.
Today i worked out many problems but suddenly i got segmentation fault. would you please help me to rectify it ? i am using linux mint 14.02, paraView 14.0 64bit

narayana@narayana-Lenovo-G50-80 ~/OpenFOAM/narayana-2.4.0/run/tutorials/incompressible/icoFoam/cavity $ paraFoam
Segmentation fault
narayana@narayana-Lenovo-G50-80 ~/OpenFOAM/narayana-2.4.0/run/tutorials/incompressible/icoFoam/cavity $

wyldckat November 13, 2015 07:55

Greetings Narayana,

Not much information to work with. Knowing what fixes you implemented would help isolate the problem. And knowing which Linux distribution you're using would also help.

My guess, please check if which of the following commands don't result in a segmentation fault:
  1. Run only paraview:

  2. Deactivate the OpenFOAM shell environment and try again:


  3. Start a new terminal and with the OpenFOAM shell environment ready to be used, please run:

    ldd $(echo $ParaView_INCLUDE_DIR | sed -e 's=include=lib=')/ > paraviewLibraries.log
    gzip < paraviewLibraries.log > paraviewLibraries.log.gz

    The last command will tell you the path to the folder where the file "paraviewLibraries.log.gz" is located. Please attach this file "paraviewLibraries.log.gz" to your next post, because it provides details regarding which Qt and ParaView libraries it is loading.
  4. Run:

    echo $PV_PLUGIN_PATH
    ls -l $PV_PLUGIN_PATH

With the information for the previous 4 details, I might be able to diagnose the problem.

Best regards,

All times are GMT -4. The time now is 19:16.