CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   Paraview on windows 7, forced scaling of data (

mikemech September 25, 2011 08:49

Paraview on windows 7, forced scaling of data
I 'm in serious trouble with Paraview.
Everything was fine but suddenly when I tryied to load a cfd simulation, in vtk format, it displayed all the fields (except for the velocity field) in a [0,1] scale. This happened once, and everytime I try to load other vtk's with the same fields, it does the same thing.

I cheked the "information" tab in the object inspector, where it shows that all fields have been loaded successfully, each of them in the correct corresponding data range.

But when I visualise the fields in the display tab, then it doesn't show them in this data range.

My system is Windows 7 64 bit so the only way to import the simulations is .vtk files.

Does anybody have a remark??

wyldckat September 25, 2011 14:47

Greetings Mike,

Which version of ParaView are you using? If it's 3.8.0 or 3.8.1, this might be due to a certain bug. To get past this, read this post (and its thread): paraview 3.8 auto rescale doesn't work #6 - in a nutshell, try running paraview with the argument "-dr":

paraview -dr
If you are using 3.10.1, start reading here: 6.1.3 The Display panel
I want you to focus on this paragraph:

the data range may not be automatically updated to the max/min limits of a field, so the user should take care to select Rescale to Data Range at appropriate intervals, in particular after loading the initial case module;
Best regards,

mikemech September 25, 2011 16:30

Hi Bruno,
I'm using the version 3.10.1 (64-bit) and I always select "Rescale to data range", after I choose a field, and nothing happens. It is strange beacause Paraview opens the vtk file and sets the correct data ranges for each field but is unable to display the correct values. It only sets for every cell the same value so my whole field is shown red, with red corresponding in value=1.

I have no explanation of why this is happening and it's getting frustrating in the end :(

I have also tried to uninstall Paraview and reinstall it, but nothing changed :(

wyldckat September 25, 2011 17:42

Hi Mike,

Mmm... OK, two additional solutions that might work:
  • If you can export the case once again to VTK, then run foamToVTK with the option "-ascii":

    foamToVTK -ascii
  • Since you are using ParaView 3.10.1, then you can use the internal reader for OpenFOAM cases. Simply create an empty file with the extension ".foam" in the base folder of the case and open that file in ParaView.
    To create said empty file, you can run in the Windows Command Line window the following command:

    echo. > case.foam
Good luck!

mikemech September 25, 2011 17:52

Thanks for the remark Bruno!

Well, I created the empty file and I opened it in Paraview but it is empty, it doesn't load any fields nor the mesh! How can I put the data into this empty file?

Thank you!

wyldckat September 26, 2011 03:45

Hi Mike,

The "case.foam" file should remain empty and should be placed in the same folder where you have the case; it should look something like this:


If the case folder is all there with the time/iteration instances, then it should work as intended.

Best regards,

openfoam_user September 26, 2011 04:49

Hi Mike,

I had problems (scale blocked between 0 and 1 - rescale do not work) with ParaView 3.6.

I solved my problem by removing the directory

Hope it could help.


wyldckat September 26, 2011 05:00

Hi Stephane!

@Mike: the respective path in Windows 7 for the folder that Stephane mentioned is this:

C:\Users\your user name\AppData\Roaming\ParaView
Best regards,

mikemech September 26, 2011 13:11

Hi Stephane and Bruno!

Thank you so much for your help, both!!
I removed the folder C:\Users\your user name\AppData\Roaming\ParaView
and now it works perfectly again!

Maybe there was some kind of conflict in the file inside that folder, so removing it made Paraview to build it again, but correct this time!

Again, thank you very much for your help!

Best regards,

All times are GMT -4. The time now is 14:13.