CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Post-Processing (
-   -   reconstructPar error (

umby September 28, 2012 11:13

reconstructPar error
I had an error message while computer was reconstructing the field U of the solution.
The command used is:
reconstructPar -latestTime -fields "(U)"
The log is:

Create time

Create mesh for time = 0

Time = 200

Reconstructing FV fields

Reconstructing volScalarFields

Reconstructing volVectorFields


error in IOstream "/scratch-locale/test_Poli/07_all_layers_laminar/200/U" for operation Ostream& operator<<(Ostream&, const UList&)

file: /scratch-locale/test_Poli/07_all_layers_laminar/200/U at line 35.

From function IOstream::check(const char*) const
in file db/IOstreams/IOstreams/IOstream.C at line 108.

FOAM exiting

I had the same message also using :
reconstructPar -latestTime
In this case the scalar fields were reconstructed, while at first vector fields (U) reconstruction was stopped.

The model is really big, about 130MLN of cells.

what is the reason of this error?how can I solve this problem?

wyldckat October 1, 2012 17:15

Greetings Umberto and welcome to the forum!

OK, I think this is not enough information to infer the reason why it crashes.

Here's the information I think is missing from your description:
  1. If your mesh has 130 million cells, then how much RAM does your workstation have?
  2. You can also (sort-of) test if you have enough RAM by running checkMesh in parallel on your workstation, something like:

    foamJob -s -p checkMesh -constant
  3. The mesh you have, does it exist in both serial and parallel forms? Or only in parallel?
Best regards,

umby October 2, 2012 05:58

Hi Bruno!
thanks a lot for your replay!

1- I'm using a workstation with 6cpu and a RAM of 72Gb for the reconstruction, while the mesh was genereted using 8 workstation with 12 cpu and RAM of 24GB each (total 96 cpu). I'm using workstation with 6 cpu to reconstruct the model because it has more RAM, but maybe it isn't enought!
2- I've tested the RAM of 96 cpu with checkMesh in parallel.It worked!now I will try if it work on the workstation where I've tried to reconstruct it.
3- I've just recostructed mesh so I have mesh recostructed and mesh decomposed!After that I've tried reconstructPar, but it crashed on the vectorial field U.
I don't know how it is possible but I've tried to recostruct the mesh again in an other folder and at this time workstation wasn't able to recostruct mesh again!

If you have any suggestions to solve this problem I can try it!
thanks a lot!
Best regards,

wyldckat October 2, 2012 16:01

Hi Umberto,

Well, it all depends on what you need to do with the results. You could use the internal reader in ParaView, which provides the ability to load parallel data into a single machine:

paraFoam -builtin
Or create a dummy file "case.foam" inside the case folder and then open that file in ParaView. To create the dummy file:

touch case.foam
Another possibility would be to do some of the necessary post-processing using the OpenFOAM application sample in parallel.

Best regards,

gomeslorenzo May 27, 2015 10:37

I had this problem once and it was lack of memory. Maybe you need to create some space in your HD.

All times are GMT -4. The time now is 18:15.