CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Post-Processing (
-   -   Having Problems with foamToTecplot360 (

Santiago March 26, 2013 12:18

Having Problems with foamToTecplot360
Hy guys,

So I've been trying to generate the mesh and the solution from OF to tecplot and this is what I obtain:

(Note: the gray area are my boundaries and the "edges" is my solution)

The weird thing is that this only happens when I run yPlusRAS to the specific solution time. Anyone has any idea??


wyldckat April 1, 2013 14:37

Greetings Santiago,

I don't have Tecplot, so I cannot test it. But from your description, all I can suggest is to:
  1. Check the options that foamToTecplot360 has got:

    foamToTecplot360 -help
  2. Among them you'll find the option "-fields". This allows to to convert only a specific list of fields.
  3. Try converting one field at a time and opening in Tecplot.
This way you might be able to confirm if the problem is due to the extra field "yPlus" or not.

Best regards,

Santiago April 1, 2013 15:07

I have done that
First off, Thanks for the reply Bruno...

Now getting down to business, as I stated in the title of this thread I have already done that and it seems to me that the problem is coming from the yPlus fields that messes up things. I have already post-processed much of my simulation results but I haven't been able to fix this problem (I have found a way around it, not very efficient though).

Anyways, I'd be nice to know whether there's a bug in the foamToTecplot360 utility.


wyldckat April 1, 2013 18:11

Hi Santiago,

Well, my theory is that the Tecplot format used by foamToTecplot360 has problems with either one of the following situations:
  1. It might have a limit on the number of fields it can export into a single data results file.
  2. Or it doesn't like that there is a scalar field after a vector field, something like:


But like I wrote before, I don't have Tecplot to confirm this myself :rolleyes:

By the way, isn't the latest Tecplot 360 able to open OpenFOAM cases directly? Or does it still have some issues?

Best regards,

Santiago April 1, 2013 18:15

Maybe I'll just install the newest Tecplot360 then (I'm not a particular fan of upgrading software in the middle of a project but well...)

mhaghdoost March 15, 2015 09:31

same issue here :/
anyone a workaround?

Santiago March 16, 2015 07:48

@mhaghdoost Try to use the openfoam loader from tecplot directly. Bruno was right about Tecplot not liking scalar fields after vector fields in .dat files.

wyldckat March 21, 2015 20:44

Greetings to all!

I was curious about this and I went to check the source code. And all indicates that the fields are stored in the correct order namely:
  • 1st are all of the scalar fields.
  • 2nd are all of the vector fields.

Therefore, can one of you test something for me?
I ask this because I don't have Tecplot to test this with, so here's the request:
  1. Get a copy of the tutorial case "incompressible/simpleFoam/pitzDaily" from OpenFOAM's tutorials folder and run inside the copied folder:

  2. After that, run yPlusRAS (without any additional options).
  3. Tun foamToTecplot360 (without any additional options).
  4. Now open the files created in the new folder "Tecplot360" in Tecplot and check if the reported problem occurs.
  5. If it does occur, then continue these steps. If not, then please let me know.
  6. Now remove the file "0/y".
  7. Then run foamToTecplot360 (again, without any additional options).
  8. Now open the files from the updated folder "Tecplot360" and check if the reported problem still occurs.
If the problem no longer occurs at step #8, then it's because the problem only occurs when there are fields that are only present in a few time snapshots. This makes sense, because the "*.plt" files are all in binary format, which means that if the "array" of data fields is of a different size for each "*.plt" file, then it's only natural that there is a problem when loading the files for representation.

If this guess is correct, then this will likely also mean that this utility foamToTecplot360 cannot be used in cases with dynamic mesh refinement, i.e. when the cell count in the mesh increases or decreases.

Best regards,

mhaghdoost March 26, 2015 08:43


Originally Posted by Santiago (Post 536473)
@mhaghdoost Try to use the openfoam loader from tecplot directly. Bruno was right about Tecplot not liking scalar fields after vector fields in .dat files.

thank you.. I just didn't know about the openfoam loader in tecplot. There is indeed one from the secoend release of tecplot 360 2011. Thx mate. It solved my problem :)

All times are GMT -4. The time now is 10:39.