CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Post-Processing (
-   -   Post-process of a decomposed case (

Pj. May 28, 2013 00:53

Post-process of a decomposed case
Hi everybody,

I'm trying to post-process a decomposed case. I've tried two ways but no one worked.

I tried to postprocess the case using the parafoam -builtin command, but when i set the case type to "decomposed" I receive the following error:


ERROR: In /usr/local/OpenFOAM/ThirdParty-2.1.1/ParaView-3.12.0/VTK/Filtering/vtkExecutive.cxx, line 756
vtkPVCompositeDataPipeline (0xd920160): Algorithm vtkPOpenFOAMReader(0xd90eba0) returned failure for request: vtkInformation (0xd8f9540)
  Debug: Off
  Modified Time: 71379
  Reference Count: 1
  Registered Events: (none)


I tried then to reconstruct the case. But reconstructPar gives me this error.


Cannot find file "points" in directory "polyMesh" in times 0 down to constant
In the 0 folder I have a polyMesh folder created by refineMesh that contain a cellmap.gz file, but all the points.gz faces.gz owner.gz etc files are in constant/polymesh folder. Anyway I tried both renaming the 0/polymesh folder and copying the constant/polymesh folder in 0/polymesh folder, but the error remains there.

How can I postprocess this case? And why I'm getting these errors?

idefix October 23, 2013 07:02


I had also the same error massage:
Create time

Create mesh for time = 0

Cannot find file "points" in directory "polyMesh" in times 0 down to constant

From function Time::findInstance(const fileName&, const word&, const IOobject::readOption, const word&)
in file db/Time/findInstance.C at line 188.

FOAM exiting
I just use the folder 0, constant and system and created a new case with them.
I used decomposePar and after that I realized that there is constant - folder in each processor-folder.
In the original case (where I get the error massage) were no constant - folder in the processor-folder any more.
So I just copied the constant folder from the processor-folder from my new case to the old case and tried reconstructPar again. And it worked :)

Maybe this could help you too


Pj. October 23, 2013 08:27

Thank you. i don't need it anymore, but someone maybe does.

Thank you very much. bye

fsifsi September 24, 2017 04:39

really appreciate ! it helps me alot

All times are GMT -4. The time now is 07:39.