CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Post-Processing

yPlusRAS error: "cannot open file"

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 8, 2015, 06:45
Default yPlusRAS error: "cannot open file"
  #1
New Member
 
jaydeep
Join Date: Sep 2015
Location: Pune, Maharashtra, India
Posts: 7
Rep Power: 3
jaydeepKhajure is on a distinguished road
Hello,

Currently I am running the case in OpenFOAM 2.3.0. I am having a problem calculating the y plus value. My case is in sonicfoam having Re 3e6 and I am using K-Epsilon RAS model. However, after post processing I type the command yPlusRAS in terminal, I get following error message,

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
Create time

Create mesh for time = 0

Time = 0
Calculating wall distance

Writing wall distance to field y

Reading field U

Reading/calculating face flux field phi



--> FOAM FATAL IO ERROR:
cannot open file

file: /home/cae/OpenFOAM/cae-2.3.0/run/jaydeep/Pen_3D_4.5/constant/transportProperties at line 0.

From function regIOobject::readStream()
in file db/regIOobject/regIOobjectRead.C at line 87.

FOAM exiting

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
Can anybody suggest a possible solution to overcome this error message ?

Thanks and Regards
jaydeep

[ Moderator note: moved post from http://www.cfd-online.com/Forums/ope...-values-2.html and deleted the duplicate posts. ]

Last edited by wyldckat; October 10, 2015 at 09:30. Reason: see "Moderator note:"
jaydeepKhajure is offline   Reply With Quote

Old   September 8, 2015, 06:51
Default
  #2
Senior Member
 
romant's Avatar
 
Roman Thiele
Join Date: Aug 2009
Location: London, UK
Posts: 368
Rep Power: 13
romant is on a distinguished road
Quote:
Originally Posted by jaydeepKhajure View Post
Hello,

Currently I am running the case in OpenFOAM 2.3.0. I am having a problem calculating the y plus value. My case is in sonicfoam having Re 3e6 and I am using K-Epsilon RAS model. However, after post processing I type the command yPlusRAS in terminal, I get following error message,

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
Create time

Create mesh for time = 0

Time = 0
Calculating wall distance

Writing wall distance to field y

Reading field U

Reading/calculating face flux field phi



--> FOAM FATAL IO ERROR:
cannot open file

file: /home/cae/OpenFOAM/cae-2.3.0/run/jaydeep/Pen_3D_4.5/constant/transportProperties at line 0.

From function regIOobject::readStream()
in file db/regIOobject/regIOobjectRead.C at line 87.

FOAM exiting

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
Can anybody suggest a possible solution to overcome this error message ?

Thanks and Regards
jaydeep
Your problem has nothing to do with the thread which has been tried to solve here. Please open a new thread for your problems or try to find similar threads. Also, by posting multiple times you make forum threads unreadable. This forum is supported by volunteers, which will help when they have time and there is no need to post multiple times to speed up the process.

BTW, when you read your error message carefully you will see that you are missing a file which the solver needs to read. In your case transportProperties.
__________________
~roman
romant is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding solvers from DensityBasedTurbo to foam-extend 3.0 Seroga OpenFOAM Installation 9 June 12, 2015 17:18
SparceImage v1.7.x Issue on MAC OS X rcarmi OpenFOAM Installation on Windows, Mac and other Unsupported Platforms 4 August 14, 2014 06:42
OpenFOAM without MPI kokizzu OpenFOAM Installation 4 May 26, 2014 09:17
centOS 5.6 : paraFoam not working yossi OpenFOAM Installation 2 October 9, 2013 01:41
build problem swak4Foam OF 2.2.0 mcathela OpenFOAM Installation 14 April 23, 2013 13:59


All times are GMT -4. The time now is 02:32.