CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Post-Processing

Problems generating xy files after executing foamLog

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 28, 2016, 12:54
Default Problems generating xy files after executing foamLog
  #1
Senior Member
 
ArielJ
Join Date: Aug 2015
Posts: 122
Rep Power: 3
arieljeds is on a distinguished road
Hi everyone,

I am running a case for a simple wave tank to using the application waveFoam (https://openfoamwiki.net/index.php/Contrib/waves2Foam). I am running the case successfully and outputting to a logfile.

However, when, after running, I execute:

foamLog log.wavefoam

I get the following output:

Code:
Using:
  log      : log.waveFoam
  database : /home/ariel/OpenFOAM/OpenFOAM-2.3.0/bin/tools/foamLog.db
  awk file : ./logs/foamLog.awk
  files to : ./logs

Executing: awk -f ./logs/foamLog.awk log.waveFoam
awk: ./logs/foamLog.awk:11:     alpha.waterCnt=0
awk: ./logs/foamLog.awk:11:          ^ syntax error
awk: ./logs/foamLog.awk:12:     alpha.waterFinalResCnt=0
awk: ./logs/foamLog.awk:12:          ^ syntax error
awk: ./logs/foamLog.awk:13:     alpha.waterItersCnt=0
awk: ./logs/foamLog.awk:13:          ^ syntax error

Generated XY files for:
alpha1Max
alpha1Min
alpha.water
alpha.waterFinalRes
alpha.waterIters
contCumulative
contGlobal
contLocal
CourantMax
CourantMean
executionTime
pcorr
pcorrFinalRes
pcorrIters
p_rgh
p_rghFinalRes
p_rghIters
Separator
Time
Ux
UxFinalRes
UxIters
Uy
UyFinalRes
UyIters
Uz
UzFinalRes
UzIters
End
While this looks great, when I actually go into the logs directory, the only file there is: foamLog.awk

I've had this issue in the past with not being able to properly generate xy files but I never sorted it out! Does anyone have advice on this?
arieljeds is offline   Reply With Quote

Old   September 18, 2016, 04:52
Default Same Problem
  #2
New Member
 
Join Date: Aug 2016
Posts: 1
Rep Power: 0
Tanne is on a distinguished road
Hey

I've got the same problem. Do you find a solution for it?

Thanke you
Tanne is offline   Reply With Quote

Reply

Tags
awk file, foamlog, function object, post processing

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM15 paraFoam bug koen OpenFOAM Bugs 19 June 30, 2009 10:46
Problems with result files Kasper CFX 5 December 14, 2006 03:41
Problems with exporting and importing CAS files .. Danny FLUENT 0 September 16, 2005 10:47
problems with .RSI files Vladimir Krejci CD-adapco 0 October 29, 2001 07:29
Problems with .bnd files Thomas CD-adapco 6 July 31, 2001 16:44


All times are GMT -4. The time now is 19:03.