CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Post-Processing

wrong result using "interpolate" on postProcess cuttingPlane

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   August 26, 2019, 18:42
Default wrong result using "interpolate" on postProcess cuttingPlane
  #1
New Member
 
Join Date: Jan 2013
Posts: 16
Rep Power: 8
Za-ck is on a distinguished road
Hi,

I would like to plot the alpha field on a cutting plane using the runTimePostProcessing tool. Everything looks right without interpolation, but with activated interpolation the values seems to get mixed up. Same error on an isoSurface. No problems using a plane instead of a cuttingPlane.

Any ideas?

Cheers,
Za-ck

Code:
/*--------------------------------*- C++ -*----------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  v1906                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.com                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
FoamFile
{
	version     1906;
	format      ascii;
	class       dictionary;
	location    "system";
	object      visualization;
}


functions
{
    planes
    {
        type            surfaces;
        libs            ("libsampling.so");

        writeControl    writeTime;
        writeFields     true;

        fields          (alpha.water);

        surfaceFormat   none;

        store           true;

        //cell cellPatchConstrained cellPoint cellPointFace cellPointWallModified pointMVC
        interpolationScheme cellPoint; 

        

        surfaces
        {
            xPlane
            {
                type            cuttingPlane; //plane; //
                planeType       pointAndNormal;
                interpolate     true;
//                 regularise      false;
                pointAndNormalDict
                {
                    point   (0 0 0);
                    normal  (1 0 0);
                }
             }            
                
         };

    }



    postPro1
    {
        #includeEtc "caseDicts/postProcessing/visualization/runTimePostPro.cfg"

        // Time control etc
        writeControl    writeTime;

        output
        {
            name        image;
            width       1920;
            height      1200;
        }
        
        
        
        camera
        {
            nFrameTotal     1;
            parallelProjection  no;
            position        (-20 0 0);
            focalPoint      (-1 0 0.0);

            up              (0.0 0.0 1.0);
        }

        // Default colours
        colours
        {
            ${..colourScheme.paraview};
        }

        surfaces
        {
            //A cutting plane from sampled surfaces:
            stored1
            {
                type            functionObjectSurface;
                functionObject  planes.xPlane; //planes.freeSurface; //planes.test2; //
                colourMap       coolToWarm;
                representation  surface;
                visible         yes;
                featureEdges    no;
                colourBy        field;
                field           alpha.water;
                range           (0.0 1.0);
                opacity         1;

            }
  

        }
        
        text
        {
            
        }

    }

}
Attached Images
File Type: jpg correct.jpg (17.0 KB, 8 views)
File Type: jpg wrong.jpg (75.0 KB, 10 views)
Za-ck is offline   Reply With Quote

Old   August 28, 2019, 10:08
Default
  #2
New Member
 
Join Date: Sep 2018
Posts: 20
Rep Power: 2
tecmul is on a distinguished road
I'm confused about what the "interpolate" switch does. Doesn't sampling on a plane always need some form of interpolation?
tecmul is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ansys outputs obviously wrong result on a simple static mechanical problem, why? cli21 Structural Mechanics 6 March 23, 2017 13:40
Wrong result Heat Transfer in a Cavity abhinav.abhi19 FLUENT 5 February 21, 2014 11:31
Pressure result wrong!!!!!!! lehoanganh07 FLUENT 4 January 10, 2014 08:20
How to plot variable (alpha1) on cuttingPlane (runtime postprocessing) pythag0ra5 OpenFOAM Post-Processing 1 September 26, 2013 08:46
Wrong result with bilinear interpolation zonexo Main CFD Forum 1 June 12, 2007 15:55


All times are GMT -4. The time now is 16:54.